Reply
 
Thread Tools Display Modes
Old 09-29-2011, 11:21 AM   #1
Junior Member
 
Join Date: Sep 2011
Posts: 11
Concertone Output

I have a new Forest River GTS 21 foot MH with a concernton zx690/700 radio. Instructions state load DVD and press setup on the radio and it will show on the TV screen. That does not work, only the sound but no picture. Can anyone help me? It's too far to take it back for a while. Everything else seems to work just fine. Thanks a lot.
__________________

__________________
Mick is offline   Reply With Quote
Old 09-29-2011, 11:22 AM   #2
Junior Member
 
Join Date: Sep 2011
Posts: 11
Concernton zx690/700 radio

Quote:
Originally Posted by Mick View Post
I have a new Forest River GTS 21 foot MH with a concernton zx690/700 radio. Instructions state load DVD and press setup on the radio and it will show on the TV screen. That does not work, only the sound but no picture. Can anyone help me? It's too far to take it back for a while. Everything else seems to work just fine. Thanks a lot.
__________________

__________________
Mick is offline   Reply With Quote
Old 09-29-2011, 11:37 AM   #3
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,157
The video output of the Z-690/700 is a composite video cable (yellow) that terminates in a RCA plug.

You must select the input on your television that corresponds to the composite input. (Check to make sure that it is connected to the TV!)

Note that you must mute the TV's audio since the DVDs audio will be playing through the Concertone and not the TV. The TV will only be used as a "monitor" to show the DVD video.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 10-06-2011, 01:05 PM   #4
Captain of Industry
 
Join Date: Jan 2010
Location: Frisco, TX
Posts: 27
I have the same problem with my Concertone... DVD is playing and sound is coming through the speakers; however, no video on the TV. I pulled the cable and validated it was plugged into the correct input, made sure it was on the correct input and still nothing.

I also discovered that it will not tune to radio stations now. My antenna is still there, at the very least, but no idea what to do with it.

The rig is still under warranty, but it's a pain to manage this...
__________________
2013 Ram 2500 HEMI 3.73
2011 Puma 259RBSS fifth wheel
jdudd is offline   Reply With Quote
Old 10-06-2011, 03:49 PM   #5
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,157
Quote:
Originally Posted by jdudd View Post
I have the same problem with my Concertone... DVD is playing and sound is coming through the speakers; however, no video on the TV. I pulled the cable and validated it was plugged into the correct input, made sure it was on the correct input and still nothing.

I also discovered that it will not tune to radio stations now. My antenna is still there, at the very least, but no idea what to do with it.

The rig is still under warranty, but it's a pain to manage this...
Model number of concertone and TV?
Is the TV on the correct input?
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 10-12-2011, 03:47 PM   #6
Captain of Industry
 
Join Date: Jan 2010
Location: Frisco, TX
Posts: 27
Lou - I have a ZX75 and it is on the AV input for a Vizio flat screen (don't know model number, but that may be irrelevant).

I triple checked it was on the correct input for the TV and even pulled it off the wall to ensure the connection was good. TV worked through the antenna and the cable hookup this weekend, but that is a coax connection, so... not necessarily relevant.

Still have the problem with tuning the radio. My antenna looks good from what I could see of it.
__________________
2013 Ram 2500 HEMI 3.73
2011 Puma 259RBSS fifth wheel
jdudd is offline   Reply With Quote
Old 10-12-2011, 04:16 PM   #7
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
Quote:
Originally Posted by herk7769 View Post
The video output of the Z-690/700 is a composite video cable (yellow) that terminates in a RCA plug.


Note that you must mute the TV's audio since the DVDs audio will be playing through the Concertone and not the TV. The TV will only be used as a "monitor" to show the DVD video.
No need to mute the audio on the TV as there is no audio being fed from the Concertone. The audio cables on the TV are audio out and are to feed audio to the Concertone when watching TV and you want the sound through the surround speakers.

As to the OP's issue, I would try taking another video cable and connectiong it to the Video out on the Concertone and video in on the TV(should be yellow female RCA connectors) just to confirm you do not have a bad cable.
__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Old 10-12-2011, 04:21 PM   #8
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
Quote:
Originally Posted by jdudd View Post
I pulled the cable and validated it was plugged into the correct input, made sure it was on the correct input and still nothing.
Just to be clear, you are plugging the Video cable into the VIDEO OUT on the Concertone not the Video input and the VIDEO INPUT on the TV as it seems by your description above you are going input to input.
__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Old 10-13-2011, 11:08 AM   #9
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
My question would be did these ever work?

If no, then checking wiring from Concertone all the way to Radio is required.

If yes, what happened when it stopped working?
__________________

__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:23 AM.