Reply
 
Thread Tools Display Modes
Old 06-09-2008, 10:49 PM   #1
Member
 
gillguy's Avatar
 
Join Date: Mar 2008
Posts: 33
Concertone static/pop noise

I know there are a lot of complaints about the Concertone and I've had my share. I'm on my 3rd -4th can't keep track of them anymore. Any way I wanted to post this as a separate thread, even though there are complaints in other post concerning the same thing. Or at least close to it. On my newest unit it worked great the first time out, then the next trip it started making a steady popping noise, not very loud, but annoying. You could turn up the volume to drown it out, but it was still there.
Since my TT is out of warranty and FR doesn't want to help anymore I pulled the unit back out to start checking wires. I wasn't crazy about the wire ties , one had come off, so I bought some Euro style terminal strips to connect the wires and replace all the wire ties, all 22 of them. Once this was done I reconnected the unit and discovered the popping noise had decreased, so I figured it had to be a ground issue. I pulled the 15AMP fuse for the TV and the noise was gone. Then I connected a long wire to the TT frame so knew I had a good ground then temp connected it to the ground wires in the terminal strip. Noise went away. Now I had to find a good ground inside the cabinet area behind the Concertone. Ended up dropping a length of wire down inside the wall and fishing it over to the bottom cabinet and securing it to an aluminum stud.
Hope this helps anyone with this type of noise problem.
Lets see if I can add a few pics.



__________________

__________________
Bobby (USAF Retired)
2007 Chevy 2500 LBZ Duramax C/C, S/B 4X4
2006 Rockwood 8317SS
1973 Airstream Ambassador
Old Town Penobscot 16
gillguy is offline   Reply With Quote
Old 06-10-2008, 06:24 AM   #2
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 6,740
Good post, thanks for the info and pictures!
I thought you were hot on the trail of my problem but I have
Morse code beep, beep, beep in the background when I watch
a DVD movie.
Also constant hiss when listening to music CDs as well as FM radio.
I just sent my 2nd one back last evening.

On a similar note-- when I was re-arranging my tongue mounted
LP tanks and battery boxes I found they had simply fastened
the 12v ground wire under the screw that mounts the emergency
breakaway switch. It wasn't even all that tight and there was already
some rust under it!!
I ran a dedicated #8 ground wire from the batteries all the way back
to the power center and landed it on the ground/neutral buss.

Cleaning up that wire mess behind my Concertone is next on my list!!
__________________

__________________
Peace!
Dan & Rita D
2004 5.3L Silverado 1500 ext. cab 2WD
1999 Suzuki Intruder Motorcycle
Blue Ox WD hitch, AirLift load levelers

Camping days 2010-53, 2011-47, 2012-41,
2013-41, 2014-31, 2015-40, 2016-44, 2017-63
KyDan is offline   Reply With Quote
Old 06-10-2008, 07:39 AM   #3
Member
 
gillguy's Avatar
 
Join Date: Mar 2008
Posts: 33
Dan
Do you have XM? If so disconnect it and it should solve your hiss.
__________________
Bobby (USAF Retired)
2007 Chevy 2500 LBZ Duramax C/C, S/B 4X4
2006 Rockwood 8317SS
1973 Airstream Ambassador
Old Town Penobscot 16
gillguy is offline   Reply With Quote
Old 06-10-2008, 08:11 AM   #4
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 6,740
Quote:
Originally Posted by gillguy View Post
Dan
Do you have XM? If so disconnect it and it should solve your hiss.
I wish it was that easy. We don't have XM radio but I want one!

Also, our first Concertone was just loud. Even on volume level 1 it
was too loud in the "bedroom" when watching a DVD.
THIS one starts out OK and gets louder as we watch.
Last time we watched a movie I had to turn it down 3 times
before the movie was over- volume number didn't
change but it just got louder and louder.... sheesh they are crap.

This is the ONE big thing that keeps us from being totally satisfied
customers.
It feels like Forest River just doesn't care whether they work or not.
__________________
KyDan is offline   Reply With Quote
Old 06-16-2008, 02:07 PM   #5
Junior Member
 
Join Date: Jun 2008
Posts: 3
Hello,

What amp trip did you use?
__________________
jeffreysee is offline   Reply With Quote
Old 06-16-2008, 02:19 PM   #6
Site Team
 
KyDan's Avatar
 
Join Date: Mar 2008
Location: Louisville, KY
Posts: 6,740
Quote:
Originally Posted by jeffreysee View Post
Hello,

What amp trip did you use?
What???
__________________
KyDan is offline   Reply With Quote
Old 06-16-2008, 04:11 PM   #7
Junior Member
 
Join Date: Jun 2008
Posts: 3
My bad. Too eager to reply. I wanted to know what amp load his terminal strips were rated at.
__________________
jeffreysee is offline   Reply With Quote
Old 06-18-2008, 10:55 PM   #8
Senior Member
 
Dodge Guy's Avatar
 
Join Date: Oct 2006
Posts: 753
Here is my fix for the Concerthole!



I had my neighbor make me a wood panel to cover up the existing hole and I installed a JVC car stereo with remote and front aux. input (for the DVD surround). I installed an extra amp I had to run the subwoofers in the ceiling. the sound is not even compareable to the Concertone!



I installed these push on/off switches to turn off and on the outside speakers and the inside rear speakers. I just fade the radio to the rear, the outside speakers are wired in with the rear speakers then I can just turn off the inside rears and turn on the outside speakers.

I have approx. $110 invested in this if I had to by the amp figure another $50
__________________
02 Ford Excursion V-10 4.30 gears 5 Star Tuner Y-pipe mod Hellwig sway bar Rear Airbags
Prodigy and Dual Cam
07 Cherokee 32B
Better to have a bad day of camping than a good day at work!
Dodge Guy is offline   Reply With Quote
Old 06-30-2008, 02:11 PM   #9
Junior Member
 
Join Date: Jun 2008
Posts: 3
OK...the Jensen AWM970 unit is available ONLY through ASA Electronics distributors (Kingston Sales, (866-733-2820)). They are getting $199 for it.
__________________

__________________
jeffreysee is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:43 PM.