Reply
 
Thread Tools Display Modes
Old 08-15-2017, 02:01 PM   #241
Junior Member
 
Join Date: Jun 2016
Location: Lafayette, LA
Posts: 2
Question concertone RV2004D

no audio but power,old but was working and so is the original remote
__________________

__________________
staciecopell is offline   Reply With Quote
Old 08-15-2017, 03:44 PM   #242
Junior Member
 
Join Date: Jun 2017
Posts: 23
No, All the new ones that I have seen the fuse if for the unit if you have tried a new fuse and that keeps blowing try disconnecting the speakers. If that works look at the wiring are the speakers you may have a short in either one or speakers are bad. If it blows this fuse with it disconnected the audio output IC or something else internal maybe bad.In either case make sure to check the wiring and speakers because if you install a new radio you will have the same problem either right away or down the road.
__________________

__________________
Fly YX is offline   Reply With Quote
Reply

Tags
led pad

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:41 AM.