Thread Tools Display Modes
Old 09-07-2009, 08:31 AM   #1
Junior Member
Join Date: Sep 2009
Location: California, Md
Posts: 6
Concertone ZX500

I have a ZX500 in my 2007 Rockwood. The radio stopped working. It also has no memory. If you turn it off or go to another option, the radio reverts back to 87.5. I have checked the fuses behind the unit and they are good. Maybe another fuse???? If anyone has a guess.

squeers is offline   Reply With Quote
Old 09-07-2009, 09:03 AM   #2
Site Team
KyDan's Avatar
Join Date: Mar 2008
Location: Louisville, KY
Posts: 5,648
In a car radio there are 2 power sources.
One in on when the key is on.
One is on all the time so the clock and radio preset memory
can function.

On a Concertone there is only one power source as far as I know.
Since you are shutting off the concertone using the remote
or power button on the face- the radio station preset memory should work unless you shut
off the main power to the unit. This would be like pulling
the fuse in the fuse box or turning off your battery switch if
you have one.

Sounds like another Concertcrap is getting ready to bite the dust!
And you're "just" out of warranty!
If it makes you feel any better, there are many, many of us out
here that have not had good luck with ours either.
They are IMO the single biggest complaint generator over all.

There used to be a tech who lurked here.
He worked as a repair technician for Forest River.
They laid him off when the economy tanked......

Several here have replaced their units with a Jensen AWM970 or 950

There have been several threads here in the tech forums about
the switch.

Good luck!

Dan & Rita D
2004 5.3L Silverado 1500 ext. cab 2WD
1999 Suzuki Intruder Motorcycle
Blue Ox WD hitch, AirLift load levelers

Camping days 2010-53, 2011-47, 2012-41,
2013-41, 2014-31, 2015-40, 2016-38
KyDan is offline   Reply With Quote
Old 09-07-2009, 10:50 AM   #3
Junior Member
Join Date: Sep 2009
Location: California, Md
Posts: 6
Thanks KyDan,
I figured as much. I had a speaker problem well I first purchased the trailer, but fixed it myself. I heard alot of horror stories then. I figured I was lucky. I guess my luck has run out.
squeers is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:56 AM.