Reply
 
Thread Tools Display Modes
Old 05-23-2013, 09:21 PM   #1
Junior Member
 
Join Date: May 2013
Posts: 8
Concertone zx500 not powering up

Bob,

Please help me diagnose a radio that red light is on but will not power up.
I recently purchased a 2006 Forest River Cardinal fifth wheel and the conncertone ZX500 (pretty sure) wasn't working so I am not at all familiar with this system. Please direct me in the correct steps to check this unit to see if it could be something simple. Thanks very much Mr. Fields.
__________________

__________________
Sherrytcombs is offline   Reply With Quote
Old 05-23-2013, 09:48 PM   #2
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
I am sure Mr. Fields will be by fairly soon. Until he does, here are some things to try and the manual if you need it.

Remove all power from the radio (easiest is to unplug shore power and remove the ground wire from the battery for one minute), then reconnect the battery cable and the shore power.

This should reset the radio and clear any errors.
Attached Files
File Type: pdf ZX500Concertone.pdf (1.52 MB, 147 views)
__________________

__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 05-23-2013, 10:40 PM   #3
Junior Member
 
Join Date: May 2013
Posts: 8
Thanks

Thanks so much, I will definitely try that. I have taken the fuse out and put back, but no luck. I will get back to you as how your suggestion goes, I may need help with doing that as well. Thanks again.
__________________
Sherrytcombs is offline   Reply With Quote
Old 05-30-2013, 08:09 PM   #4
Junior Member
 
Join Date: May 2013
Posts: 8
Concertone ZX500

I have identified that I have the concertone zx500. I also found 4 wires that are crimped. the are tan and tan & black wires. Could that be an issue. I cannot find were these would go. I just bought this rv and am very unfamiliar with the system. Please help if you can. I have taken the fuse out and I still have the red light but no power. Any help would be greatly appreciated.
__________________
Sherrytcombs is offline   Reply With Quote
Old 05-30-2013, 08:18 PM   #5
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Quote:
Originally Posted by Sherrytcombs View Post
I have identified that I have the concertone zx500. I also found 4 wires that are crimped. the are tan and tan & black wires. Could that be an issue. I cannot find were these would go. I just bought this rv and am very unfamiliar with the system. Please help if you can. I have taken the fuse out and I still have the red light but no power. Any help would be greatly appreciated.
Hope this manual helps.
Attached Files
File Type: pdf ZX500Concertone.pdf (1.52 MB, 80 views)
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 05-30-2013, 08:36 PM   #6
Junior Member
 
Join Date: May 2013
Posts: 8
Manual

thanks so much for your help. I have looked at the manual but i quess I am just dumb. I know nothing about wiring. Can you just kinda help me trouble shoot some things and maybe walk me thru some steps to test
__________________
Sherrytcombs is offline   Reply With Quote
Old 05-30-2013, 09:14 PM   #7
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Quote:
Originally Posted by Sherrytcombs View Post
thanks so much for your help. I have looked at the manual but i quess I am just dumb. I know nothing about wiring. Can you just kinda help me trouble shoot some things and maybe walk me thru some steps to test
I would try a hard reset first.
Turn off everything in the camper you can; lights fridge; AC; etc

Remove ALL power from the camper.
Open the main circuit breaker in the power center (or turn it off at the pole).
Remove the GROUND wire from the camper's storage battery.
No lights should be on at the radio. (Power button etc)

WAIT 1 full minute (or more).

Reconnect the GROUND wire on the battery FIRST. Might be some light sparking so be prepared for that. That is why you turn as much off before hand as you can.

Then go inside and try the radio. If it works you are done.
If not, it might be bad.

Turn the main breaker on and make sure you don't forget to turn the fridge back on.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 05-30-2013, 09:43 PM   #8
Junior Member
 
Join Date: May 2013
Posts: 8
Thanks

Thank you so much, I will definitely try that asap. I appreciate everything you are doing for me. I will let you know how that goes. Thanks again.
__________________
Sherrytcombs is offline   Reply With Quote
Old 05-30-2013, 09:50 PM   #9
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Quote:
Originally Posted by Sherrytcombs View Post
Thank you so much, I will definitely try that asap. I appreciate everything you are doing for me. I will let you know how that goes. Thanks again.
There is an different way to do it if you are handy with a screwdriver and not afraid to break the radio getting it off the wall. There are two fuses back there somewhere (a always on direct to the battery for the clock and permanent memory and one on the radio fuse).

Finding them is the trick. My way is easier.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 05-30-2013, 10:25 PM   #10
Senior Member
 
QCCowboy's Avatar
 
Join Date: May 2012
Location: Illinois
Posts: 880
Follow Herk's advice......


Concertone ZX600 - Power light red, but will not come on
__________________

__________________
Jack of all trades - Master of none
2012 F350 CC DRW - 6.7L PSD
2014 Sabre 36QBOK
QCCowboy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:47 AM.