Reply
 
Thread Tools Display Modes
Old 05-09-2016, 09:26 PM   #1
Junior Member
 
Join Date: Apr 2016
Posts: 15
Question Concertone ZX600

I have just recently purchased a '08 Lexington with a Concertone ZX600 Radio. The radio plays fine, even with CD. However, I just can't get any DVD to play to my TV. I have new coax running from my antenna and booster to my TV. I've also plugged in the 3-wire cord (Red, White, and Yellow) from my wall panel to my TV. I looked at the back of the unit and cannot see anything not plugged in.
Has anyone any ideas I might try??? We're planning on a long trip and would like to see some DVDs that we've acquired.
Thanks, Peteski
__________________

__________________
Peteski is offline   Reply With Quote
Old 05-10-2016, 05:26 AM   #2
2007 WildCat 32QBBS
 
05CrewDually's Avatar
 
Join Date: Jul 2011
Location: NJ
Posts: 1,766
The wall panel may not be plugged into the ZX600. You may need to remove the panel to make sure both ends of the leads are plugged into the panel & ZX600.
__________________

__________________
*Current: 2005 Ford F350 Crew Cab Dually 6.0 diesel 4x4*
*Retired: 1987 F350 Crew Cab Dually 6.9 turbo diesel
2007 Forest River WildCat 32QBBS
05CrewDually is offline   Reply With Quote
Old 05-10-2016, 06:56 AM   #3
Junior Member
 
Join Date: Apr 2016
Posts: 15
Concertone ZX600

Thanks, I'll check it out I don't know why I didn't think of doing that.
__________________
Peteski is offline   Reply With Quote
Reply

Tags
concertone

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:39 AM.