Reply
 
Thread Tools Display Modes
Old 04-12-2011, 05:59 PM   #1
Junior Member
 
Join Date: Apr 2011
Posts: 1
concertone Zx600

Our three year old Zx600 will not load or play dvds any longer. I was wondering if anyone could tell me whether it may be a board or the DVD player itself? If it is the DVD player can someone give me a replacement part number so can repair the problem.

Thanks
hjg3949
__________________

__________________
hjg3949 is offline   Reply With Quote
Old 04-12-2011, 08:21 PM   #2
Senior Member
 
Big Dawg's Avatar
 
Join Date: Jan 2011
Location: Columbus, Ohio
Posts: 533
You will have to do some searching on the site. I just picked up our Cherokee 28BH and it has this unit. From what I understand, there are members that have extensive problems with the Concertone products. I for one, hope that since mine is new, I do not have them...
__________________

__________________
2004 Chevy Avalanche Z66 W/Transmission Cooler
2011 Grey Wolf 28BH
Blue Ox Sway Pro WDH
2 Beagles (Snoopy & Dexter)

Big Dawg is offline   Reply With Quote
Old 04-12-2011, 08:36 PM   #3
Senior Member
 
camper_Lucy's Avatar
 
Join Date: Jan 2011
Location: Camping some place I hope
Posts: 318
Here is the web site, you will find all the contact and support information on it. Concertone® Home Page there is also a gentleman on here "Bob Fields" if I recall who may be able to provide some assistance he has helped out others in the past.
__________________
2011 GMC 3500HD 4x4 Crew DRW Duramax
Pullrite 20.5K
2012 Sierra 365SAQ
2006 Police Roadking FLHPi
camper_Lucy is offline   Reply With Quote
Old 04-18-2011, 09:01 AM   #4
Member
 
Dave T's Avatar
 
Join Date: Oct 2010
Posts: 82
I have the same problem. I bought a new 2009 lexington last fall. I had the dealer replace the orginal unit. Now this unit does the same thing! I haven't even spent ONE night in this unit. These RV manufactures just keep putting in junk! I should have done more research into Forest River before buying. I never new about this forum until after buying!
On the Concertone web site, you can up grade to a XZ690. Worth the money????
Another thing to try is to shut off the power to the unit. I never did find the fuse, so I removed the unit & unplugged the power. It would play good for about 20 seconds, back to same problem!!
__________________
Dave T is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:14 AM.