Reply
 
Thread Tools Display Modes
Old 11-20-2010, 07:20 PM   #1
Member
 
Join Date: Nov 2010
Posts: 38
concertone ZX700 DVD/media player defect?!

Concertone ZX700 DVD/media player defect?! I just bought a new Sabre TT. I absolutely love the trailer. But the DVD player (ZX700) I do not like. All video run through the device (DVD, netflix, home movies, etc) is pixilated and the whole screen jumps up a quarter of an inch every few seconds and just generally figets all around. Basically, video from the antenna looks ten times better than any DVDs we try and watch. So it's not the tv! I was really looking forward to watching some movies on our new big screen tv that came with the trailer but this problem makes the movies almost unwatchable.

Immediately I cried fowl and Forest River sent me a new unit. However, as I feared the new unit does the same exact thing. I tested changing the wiring to but it had no affect. After doing some Googling I found others complaining of the same problem with this unit on different forums. So... what's Forest River doing about this annoying problem? And/or has anyone found a fix for this??? Thanks for your time and help!
__________________

__________________
ewwatson is offline   Reply With Quote
Old 11-20-2010, 08:48 PM   #2
Senior Member
 
great white's Avatar
 
Join Date: Sep 2010
Location: Canada
Posts: 662
And here I thought it was just a glitch on the videos I was watching the other day.

I'll have to check it again.

Bob Feilds, you out there?
__________________

__________________
great white is offline   Reply With Quote
Old 11-20-2010, 11:14 PM   #3
Senior Member
 
Join Date: Aug 2010
Posts: 855
Welcome to the world of Concertone JUNK! Since you bought this unit and I assume it is still under warranty have the dealer replace it. But in the long term be prepared to either replace them about every year or scrap it and buy a quality double din unit and fit it in the place of that junk unit. As a side benefit you will see about a 300% increase in sound quality.
__________________
donn is offline   Reply With Quote
Old 11-22-2010, 10:46 AM   #4
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Quote:
Originally Posted by ewwatson View Post
Concertone ZX700 DVD/media player defect?! I just bought a new Sabre TT...
What model Sabre do you have?
__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline   Reply With Quote
Old 11-22-2010, 08:01 PM   #5
Senior Member
 
Join Date: Sep 2010
Posts: 1,702
No problems with our 700 unit at all and we have tried all the functions, so not everyone has problems with these units.
__________________

2011 Flagstaff 831FKBSS
2010 F250 4X4 5.4L 3.73 LS
EQUALIZER E4 1200/12000
lbrjet is offline   Reply With Quote
Old 11-22-2010, 11:44 PM   #6
Member
 
Join Date: Nov 2010
Posts: 38
Quote:
Originally Posted by Bob Fields View Post
What model Sabre do you have?
Thanks guys for getting back to me and sorry it took me so long to respond. My Sabre is a 31QBDS 2011. I absolutely am in love with it. Bob mentioned to me I make sure the vid setting is on NTSA (I think that was it?) and not Pal. Anyway I made that change but unfortunately it had no effect. If anyone else has a suggestion I'd me more than happy to try it. Thanks!
__________________
ewwatson is offline   Reply With Quote
Old 11-23-2010, 07:04 AM   #7
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
FWIW, our ZX700 was doing the jumping picture thing and when I called our dealer the service manager said it was the unit and she gave us a new one and the problem is solved. Still not crazy about the video quality but it is a composite signal so high def is not gonna happen. I am planning on replacing ours with a Sony Brava Micro home theatre system in the spring as our Toshiba 32" TV is 110v only and we never use the radio so having a 110v sound system makes sense to us and will have a real sub. I will keep the concertone in ceiling speakers though and as we never use the stereo the bedroom and outside speakers need not be attached.
__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Old 11-23-2010, 11:08 AM   #8
Member
 
Join Date: Jun 2010
Posts: 65
I am having the same problem with the video jumping. I checked the NTSC and they were set correctly. Mine does it whether I am playing a DVD or using the AV1 setting for the satellite. My 5er is a 2011 Rockwood 8286WS.
__________________
phoneman06 is offline   Reply With Quote
Old 11-23-2010, 11:16 AM   #9
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
Quote:
Originally Posted by phoneman06 View Post
I am having the same problem with the video jumping. I checked the NTSC and they were set correctly. Mine does it whether I am playing a DVD or using the AV1 setting for the satellite. My 5er is a 2011 Rockwood 8286WS.
Ours did it on all inputs as well, regardless of what they were, Xbox 360, External DVD player or the internal DVD player. I thought at first it was the TV but hooked up the Xbox 360 directly and it worked fine, the broadcast TV signal was ok as well.
__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Old 11-23-2010, 11:18 AM   #10
Member
 
Join Date: Nov 2010
Posts: 38
Well I have already replaced the unit with a new one and it did not remedy the problem. I have a warranty ticket open on it now so I guess I'll wait and see what happens. Worse comes to worse, I could just put in a new TV/DVD combo and then just go strait through the tv and bypass the unit altogether. But I should not have to go to such extremes to just watch a movie correctly in my brand new rig.
__________________

__________________
ewwatson is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:34 AM.