Thread Tools Display Modes
Old 07-23-2016, 07:54 PM   #1
Junior Member
Join Date: Jul 2011
Posts: 8
Crusader 320RLT A/C unit not cooling

I have a 2013 Crusader 320RLT 5th wheel and the a/c just stopped cooling, the compressor works, but no cool air. It is a 15,000BTU ducted, no part of the a/c unit is in the 5th wheel and can only access it from roof top.

Does any one know what model a/c units they came with? I have a feeling I will have to replace it.

Any ideas?

MuddaFadda is offline   Reply With Quote

cooling, crusader

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:24 PM.