Reply
 
Thread Tools Display Modes
Old 01-11-2014, 12:39 PM   #31
Senior Member
 
TxTravelingRN's Avatar
 
Join Date: Jan 2014
Location: On the Road
Posts: 128
Quote:
Originally Posted by cmptrkd View Post
Might want to check up by the battery, my buddy's Surveyer by Forest River has electric stabilizer jacks and he has a fuse right there at the terminal for each front and rear set of jacks. I hope you find it, and it's something simple.
I think I found what you're referring to (see attached photo). Would be odd for both fuses to blow simultaneously without some type of surge. I would also think if only the fuse for front jack were bad the rear jacks would be operational unless there is some mechanism shutting down all jacks if 1 pair is inoperable. No sure about that. If fuses are ok (will check a little later) then I guess I might have a ground wire loose in the bundle. Quick visual inspection doesn't reveal this. One thing is for sure...this has to be electrical in nature as front and rear use 2 different motors.
Attached Thumbnails
Click image for larger version

Name:	IMG_0339.jpg
Views:	65
Size:	55.1 KB
ID:	44775  
__________________

__________________
--------------------------------------------------

2013 F350 Lariat 6.7 Diesel DRW
2013 Rockwood Ultralite 2608 WS
2013 Days Camping: 61
2014 Days Camping: 200+
TxTravelingRN is offline   Reply With Quote
Old 01-11-2014, 01:36 PM   #32
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Looking at your DC panel, it looks like the bottom yellow 20 amp fuse is label "PSJ" for power stabilizing jack?? Just to be on safe side, I would pull it out and make sure it is not burnt.

ps: glad your furnace is fix
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 01-11-2014, 05:10 PM   #33
Senior Member
 
TxTravelingRN's Avatar
 
Join Date: Jan 2014
Location: On the Road
Posts: 128
Quote:
Originally Posted by fonzie View Post
Looking at your DC panel, it looks like the bottom yellow 20 amp fuse is label "PSJ" for power stabilizing jack?? Just to be on safe side, I would pull it out and make sure it is not burnt.

ps: glad your furnace is fix
You nailed it Fonzie. 20 amp fuse was dead, replaced, and stabs are now working.
Called service technician where I bought RV. He looked at same model on site. There is not an external fuse or reset button for this model. Everything is in the panel. Interestingly, the models at RV dealership ALL had 30 amp fuses, NOT 20. I replaced the 20 with a 30 amp as Walmart was out of the 20's. I want to test later to see if it blows a 20 when I use stabs again. Documents I received for stabs was minimal at best and doesn't indicate what proper fuse amp should be used.

Thanks for pointing out the obvious.
Attached Thumbnails
Click image for larger version

Name:	IMG_0343.jpg
Views:	79
Size:	54.8 KB
ID:	44791  
__________________

__________________
--------------------------------------------------

2013 F350 Lariat 6.7 Diesel DRW
2013 Rockwood Ultralite 2608 WS
2013 Days Camping: 61
2014 Days Camping: 200+
TxTravelingRN is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:45 PM.