Reply
 
Thread Tools Display Modes
Old 10-10-2014, 09:30 PM   #1
Junior Member
 
Join Date: Oct 2014
Posts: 17
Desperately need help with a Genesis GT 2.0

The stereo plays the DVD and we hear it but cannot get it on the tv. We have tried different sources on the tv but nothing receives it. When we push the Setup button on the stereo itself, we get nothing. There is no Setup button on the unit so we have no opportunity to check it ourselves. The Quick Start Guide says to load the DVD and it will play. Obviously, that doesn't work. I have spent three hours on this to no avail. Any suggestions would be greatly appreciated.
__________________

CampCrew is offline   Reply With Quote
Old 10-10-2014, 09:44 PM   #2
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,460
Just off the top of my head, both the DVD and the TV need to be on the right settings....I believe mine was AV on the flat screen and AV1 on the genesis. I got it confused with AU1 once and couldn't get it to work. Mine's unplugged at the moment, or I'd go outside and see what settings it is.
__________________

__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 10-10-2014, 09:50 PM   #3
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,460
OK, went outside and looked...I'm not plugged into 110, so I couldn't check the TV, but the radio should cycle through to AV1 with the "mode" button. I believe it defaults to AU1.
__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 10-10-2014, 10:00 PM   #4
Junior Member
 
Join Date: Oct 2014
Posts: 17
Thanks for responding. When I put in the DVD, it doesn't automatically cycle to AV1 but I can manually put it on there. I did that and put my tv on AV source. Still nothing. Just sound from the stereo.
CampCrew is offline   Reply With Quote
Old 10-10-2014, 10:06 PM   #5
Senior Member
 
jtstromsburg's Avatar
 
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,679
Sounds like maybe it's just a video cable not plugged in to the right port?
__________________
Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote
Old 10-10-2014, 10:13 PM   #6
Junior Member
 
Join Date: Oct 2014
Posts: 17
We have actually tried all three ports. This is so frustrating. The stereo is across the camper from the TV. It's all brand new. If the wiring itself is wrong, it's already built over by Forest River. We only have two cords (besides the electric cord). One is Video and the other is for exterior Cable/Satellite. Really appreciate you two trying to help here. You would think it would be easy....
CampCrew is offline   Reply With Quote
Old 10-10-2014, 10:56 PM   #7
Senior Member
 
Join Date: Jul 2014
Posts: 735
Quote:
Originally Posted by CampCrew View Post
We have actually tried all three ports. This is so frustrating. The stereo is across the camper from the TV. It's all brand new. If the wiring itself is wrong, it's already built over by Forest River. We only have two cords (besides the electric cord). One is Video and the other is for exterior Cable/Satellite. Really appreciate you two trying to help here. You would think it would be easy....
When you say "two cords" do you mean to wall jack connections?

What brand and model of stereo? Jensen?

Look at the connections that are physically connected to the TV. If there is only one cable (RG6 or 59 AKA cable tv cables) then you are most likely not connected to the Jensen DVD player. If there is an HDMI or RCA connection, what port does it say it is? You may need a flashlight to read it, but you will need to know that.

There should (at least there is on my trailer) be a wall jack very near the stereo with output connections. What are they on your trailer? Mine has an RCA jack for video output (yellow) that I then connect to the TV on one of several ports. The very latest Jensen has HDMI outputs. Whichever port you connect it to, is the selected input on the TV that will work.
madmaxmutt is offline   Reply With Quote
Old 10-11-2014, 09:23 AM   #8
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,460
His post title says he's got a Genesis GT 2.0 . Has it worked at all up until now, or did this just start? If it's never worked, I'd pull the unit out of the wall slightly. I've never done it, but it looks like the trim just pops off and it's screwed in from the front like a car stereo. Everything from the pictures I've seen shows the cables all being plugged in from the side. Maybe something is loose as jtstromburg suggested.
__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 10-11-2014, 10:26 AM   #9
Junior Member
 
Join Date: Oct 2014
Posts: 17
Raspivy, I am pretty sure the problem is between the stereo and the TV. You cannot see any plugs anywhere but the TV. The unit is brand new. It's the first time we've even camped in the trailer.
CampCrew is offline   Reply With Quote
Old 10-11-2014, 10:33 AM   #10
Senior Member
 
Jimandchris's Avatar
 
Join Date: Aug 2013
Location: Southeast Michigan
Posts: 613
There should be a yellow video cable connected to the tv for video in from the dvd player. What tt and brand of tv? If it's a furrion, the yellow video input doubles as one of the component inputs
__________________
2019 Coachmen Freedom Express 281RLDSLE
2018 2500 HD Silverado
Equal-i-zer Hitch E4
Jimandchris is offline   Reply With Quote
Old 10-11-2014, 10:36 AM   #11
Junior Member
 
Join Date: Oct 2014
Posts: 17
Jim, yes, the brand is Furrion. I have the yellow cable plugged into Video. There are two ports beside it that are empty that say L and R. I tried to find a brand name on the cable but cannot.
CampCrew is offline   Reply With Quote
Old 10-11-2014, 10:42 AM   #12
Senior Member
 
Jimandchris's Avatar
 
Join Date: Aug 2013
Location: Southeast Michigan
Posts: 613
The tv should be set to component input. If it still does not work, then I would pull the genesis unit, likely a cable has disconnected from it. Many on the forum have had issues with loose connections on the rear of the entertainment units.
__________________
2019 Coachmen Freedom Express 281RLDSLE
2018 2500 HD Silverado
Equal-i-zer Hitch E4
Jimandchris is offline   Reply With Quote
Old 10-11-2014, 10:57 AM   #13
Junior Member
 
Join Date: Oct 2014
Posts: 17
Jim, I cannot get the Setup to come up on the stereo. Do you think that's a concern as well? In the Quick Start guide, it says it will automatically read it (and I believe it is since it plays audio) but when I press the Setup button, it won't do anything. Maybe it has to be connecting to the TV in order to get the Setup menu?
CampCrew is offline   Reply With Quote
Old 10-11-2014, 11:26 AM   #14
Senior Member
 
Jimandchris's Avatar
 
Join Date: Aug 2013
Location: Southeast Michigan
Posts: 613
Unsure about the stereo setup, shouldn't affect the tv at all as long as the sound is working. Dvd video should be on the yellow rca connector going to the tv. On ours the dvd starts playing audio, but the tv has to be set to component input in order for the video to play on it. The left and right outputs on the the tv should also be connected so the tv sound can be played thru the stereo to all sets of speakers. Sorry I'm at work and can't go out and look at my tt.
__________________
2019 Coachmen Freedom Express 281RLDSLE
2018 2500 HD Silverado
Equal-i-zer Hitch E4
Jimandchris is offline   Reply With Quote
Old 10-11-2014, 11:40 AM   #15
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,460
I've got the same setup. I'll go pull the power cord out and plug mine in shortly and see how it's set.
__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 10-11-2014, 11:45 AM   #16
Junior Member
 
Join Date: Oct 2014
Posts: 17
That is really nice. I wouldn't have asked you to do that. Incidentally, for Jim, there is no way for me to plug in the left or right speaker without literally going under the floor up through a cabinet. I can handle no surround sound. I just want to see a movie instead of only hearing it! Thank you all again for all the helpful comments. Being brand new to this hobby, it is awesome to know there are so many nice people out there who are ready to help.
CampCrew is offline   Reply With Quote
Old 10-11-2014, 11:56 AM   #17
Senior Member
 
Jimandchris's Avatar
 
Join Date: Aug 2013
Location: Southeast Michigan
Posts: 613
Quote:
Originally Posted by CampCrew View Post
That is really nice. I wouldn't have asked you to do that. Incidentally, for Jim, there is no way for me to plug in the left or right speaker without literally going under the floor up through a cabinet. I can handle no surround sound. I just want to see a movie instead of only hearing it! Thank you all again for all the helpful comments. Being brand new to this hobby, it is awesome to know there are so many nice people out there who are ready to help.
You should be able to have the normal tv sound play back thru the genisis unit if it's connected correctly at the tv. I made the mistake of unplugging everything without taking a snapshot of the cables when I moved our tv to the outside mount. It took abit to get it all connected when I moved the tv back inside.
__________________
2019 Coachmen Freedom Express 281RLDSLE
2018 2500 HD Silverado
Equal-i-zer Hitch E4
Jimandchris is offline   Reply With Quote
Old 10-11-2014, 12:46 PM   #18
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,460
Forest River Forums - raspivey's Album: Genesis DVD settings

I keep forgetting the uploader rotates iphone pics, so you'll have to look at them sideways. The DVD will automatically go to "load" (does not need to be on AV1 like I thought). The TV needs to be on AV with the source button.
__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 10-11-2014, 12:47 PM   #19
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,460
It needs to be on AV1 to hear the TV through the trailer speakers (regular TV, not with a DVD) however.
__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 10-11-2014, 01:20 PM   #20
Junior Member
 
Join Date: Oct 2014
Posts: 17
Thanks, raspivy. I am going to start by checking the connection of the Video cable in the wall. If it's not loose, I'll pop off the front of the stereo and check connections there.
__________________

CampCrew is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:56 PM.


×