Reply
 
Thread Tools Display Modes
Old 03-25-2015, 02:04 PM   #1
Junior Member
 
Join Date: Mar 2015
Posts: 2
Question Dometic A/C Inop on Low/Med but works on High

Hi All,

Just as the subject says, my Dometic A/C (see attached pics for all model information) is not working on Low or Medium settings. This is true for both the Cool function and the Fan function. Depending on the outside/ambient temperature, you can hear the compressor kick on but the fan never works in those two modes. I am also attaching a video. Can someone walk me through troubleshooting or provide a fix if you've encountered this before?

Thanks in advance!
Rich
Attached Thumbnails
Click image for larger version

Name:	20150324_081019_resized.jpg
Views:	101
Size:	147.0 KB
ID:	72160   Click image for larger version

Name:	20150324_080948_resized.jpg
Views:	96
Size:	168.4 KB
ID:	72168   Click image for larger version

Name:	20150324_081040_resized.jpg
Views:	95
Size:	159.6 KB
ID:	72169   Click image for larger version

Name:	20150324_081232_resized.jpg
Views:	101
Size:	171.2 KB
ID:	72170  
Attached Files
__________________
aReLBee is offline   Reply With Quote
Reply

Tags
dometic

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:10 PM.