Thread Tools Display Modes
Old 09-02-2013, 11:58 PM   #1
Junior Member
Join Date: Sep 2012
Posts: 12
DSI wont try to light

2013 Rockwood ws8280

gas water heater sunbeam sw6de dsi ignition

Unit stopped trying to spark ignite.
Checked these things so far.
reset eco on heater
tried turning switch on and off waiting 30 seconds.
i checked voltage to unit i am getting 12volts to it but the red wire going to the module has none. It seems that its not making voltage back from the limit/tstat area ?

Any help would be greatly appreciated.
“We're not here for a long time; we're here for a good time.”
bradcomm is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:13 PM.