Reply
 
Thread Tools Display Modes
Old 02-10-2019, 07:44 PM   #1
Junior Member
 
Join Date: May 2017
Posts: 9
Electric fireplace will turn on but not blow any air

We have a pretty standard electric fireplace in a 2018 coachmen chaparral 360ibl. It has worked fine until today. It now lights up and show the flame but when I turn it to low or high it does not blow. Even with the temp turned up. Any ideas on fixez?
__________________

lulu86 is offline   Reply With Quote
Old 02-12-2019, 11:39 AM   #2
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 6,379
Can you give us the make and model of the fireplace?

It's possibly a loose connection inside the unit, but could also be a bad blower motor.
__________________

__________________
Salem 29RKSS Pushing a GMC Sierra 2500HD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 02-13-2019, 11:59 AM   #3
Junior Member
 
Join Date: May 2017
Posts: 9
We took it out of the hole and then is suddenly started working. Not sure if there was wire pinched or we jarred something when we moved it and that fixed it or what but it's working and fingers crossed it stays that way.
lulu86 is offline   Reply With Quote
Reply

Tags
electric, heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:07 PM.