Closed Thread
 
Thread Tools Display Modes
Old 08-21-2010, 09:53 AM   #141
Junior Member
 
Join Date: Aug 2010
Posts: 4
Hi bob,
Thanks for the reply. Do you know what model fits that and also did forrest river replace it or are we on our own?
__________________

__________________
jeffro is offline  
Old 08-21-2010, 10:27 AM   #142
Member
 
Join Date: Apr 2010
Posts: 59
Jeffro,

I replaced my 7X75 with a Jensen AWM970. It will fit, if do you some enlarging of the hole. I bought mine with my own cash and did the install myself. I got mine from American Trailer Supply on sale for $245.00, down from $295.99 (plus S/H of $11.68). Don't know what their price is now.

From what I've been reading, Concertone is listening to customer complaints and making improvements to their product. That won't help much with the units already in service. If your trailer is still under warranty, take it back to the dealer. If the radio has never worked, I would've had it back in a heartbeat. My dealer worked on mine during warranty. After the warranty expired , I replaced it as soon as it started acting up. My problem was limited to the CD/DVD only. Radio worked from the day I got it to the day I took it out. This is what it looks like installed.

__________________

__________________
Frank and Jean
Retired Navy
DAV Life Member
'09 Rockwood Roo 233s
'03 1500 Silverado LS

I didn't say it was your fault, I said I was going to blame you.
It may be that your sole purpose in life is simply to serve as a warning to others.
The things that come to those that wait will be the scraggly crappy junk left by those that got there first.
popeye59 is offline  
Old 08-25-2010, 12:58 AM   #143
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Yes we are listening! ;-)

Did you guys check the wiring???
__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline  
Old 08-25-2010, 07:51 AM   #144
Junior Member
 
Join Date: Aug 2010
Posts: 4
Hi Bob,
Yes i checked the wiring. I opened it up to make sure the antena was plugged in, it was. All wires are connected and the 3 channels all have static. I don't think wiring would keep the dvd player from loading all but 2 times?
thanks,
jeff
__________________
jeffro is offline  
Old 09-01-2010, 12:09 PM   #145
Junior Member
 
Join Date: Aug 2010
Location: Christiana, TN
Posts: 8
Quote:
Originally Posted by Fre tech View Post
Let me know what problems you are have and I will do the best I can to help you
I know all of those units.
I know this post is from 2008 but maybe someone is still answering. I just purchased a new to me 2008 model Forest River Wolfpack 27DFWP toy hauler. it has the ZX500 system in it. I tested a DVD in it this morning. The DVD picture played great on the monitor but there was absolutely no Sound. Radio and Regular Air TV has sound in all speakers. What am I doing wrong? Book doesn't help at all with this one.
__________________
JarheadTN is offline  
Old 09-01-2010, 01:05 PM   #146
Senior Member
 
miatared's Avatar
 
Join Date: Oct 2009
Location: Toronto
Posts: 704
Hello Bob.

I have a new 2011 Shamrock 19 - with a ZX75.

All works as expected, EXCEPT for the FM radio, AM works fine. CD (audio and MP3) as well as DVD playback are fine. i use it most of the time on INPUT1 to listen to my iPod.

Here is the scenario:
1. Turn ON, press Mode to get FM
2. Tune any FM station
3. Station plays fine for 30-45 seconds (LED shows sound level bouncing as it should)
4. FM starts cutting in & out (LED sound level stops and starts)
5. This only happens on FM
6. All other functions seem fine.

Have not figured out how to use the SD slot - tried to put he SD card from my Canon camera - but it would not load.... Have not had to use the USB port.

It is still under warranty, but am wondering if it could be some easy fix.

Regards,
__________________
Denis & Diane
2010 Sabre 31REDS
Ford F-250 2011
* Happy Campers *
miatared is offline  
Old 09-01-2010, 01:45 PM   #147
Junior Member
 
Join Date: Aug 2010
Posts: 4
Hi All,
My radio never worked, neither am or fm. All i get is static on each speaker. My dvd played 2 times out of the 15 or so times i've tried to use it.
__________________
jeffro is offline  
Old 09-01-2010, 04:25 PM   #148
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Quote:
Originally Posted by jeffro View Post
Hi Bob,
Yes i checked the wiring. I opened it up to make sure the antena was plugged in, it was. All wires are connected and the 3 channels all have static. I don't think wiring would keep the dvd player from loading all but 2 times?
thanks,
jeff
Understood, but you can see from many here installation has been an issue.

I believe earlier you said that you got your unit in April, so I would suggest having the dealer swap it out while it is under warranty. No sense buying a new radio if you can get it swapped.

Let me know what happens!
__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline  
Old 09-01-2010, 04:28 PM   #149
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Quote:
Originally Posted by JarheadTN View Post
I know this post is from 2008 but maybe someone is still answering. I just purchased a new to me 2008 model Forest River Wolfpack 27DFWP toy hauler. it has the ZX500 system in it. I tested a DVD in it this morning. The DVD picture played great on the monitor but there was absolutely no Sound. Radio and Regular Air TV has sound in all speakers. What am I doing wrong? Book doesn't help at all with this one.
I sent your question to support - we'll say what they say...
__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline  
Old 09-01-2010, 04:34 PM   #150
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Quote:
Originally Posted by miatared View Post
Hello Bob.

I have a new 2011 Shamrock 19 - with a ZX75.

All works as expected, EXCEPT for the FM radio, AM works fine. CD (audio and MP3) as well as DVD playback are fine. i use it most of the time on INPUT1 to listen to my iPod.

Here is the scenario:
1. Turn ON, press Mode to get FM
2. Tune any FM station
3. Station plays fine for 30-45 seconds (LED shows sound level bouncing as it should)
4. FM starts cutting in & out (LED sound level stops and starts)
5. This only happens on FM
6. All other functions seem fine.

Have not figured out how to use the SD slot - tried to put he SD card from my Canon camera - but it would not load.... Have not had to use the USB port.

It is still under warranty, but am wondering if it could be some easy fix.

Regards,
I would say get it swapped when it is convenient and STILL under warranty. The FM tuner certainly sounds FUBAR.

This is how the USB / SD works:

The unit supports SD card / USB stick with up to 2GB capacity; if the customerís SD card / USB stick has more than 2GB itís not gonna work.

The SD card/ USB stick has to be formatted with FAT file system.

The unit will play MP3 songs, MP4 audio/ video files and JPG photos.

It doesnít matter if there are other files on the SD/ USB, and it doesnít matter if the songs are in a folder, itíll work in any case.

Let me know what you do!
__________________

__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline  
Closed Thread

Tags
500

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:13 PM.