Reply
 
Thread Tools Display Modes
Old 04-05-2015, 06:51 PM   #1
Junior Member
 
Join Date: Apr 2015
Posts: 11
Furnace blows but no hot air.

Hey guys. Just bought a surveyor forester 191t hybrid trailer. I tried turning the heat on. The blower kicks in but no heat. Just cold air. Any ideas. I'm new to this. My first trailer. Lol. Furnace model is NT16SEQ
Thanks
__________________

__________________
Sac3100 is offline   Reply With Quote
Old 04-05-2015, 06:54 PM   #2
Senior Member
 
caper's Avatar
 
Join Date: Jul 2010
Posts: 1,973
Have you tried turning the stove on and purging the gas line? It might take several tries to get the furnace to light. If you do get hot air open the windows because it will smoke till you burn the new oils from the metal.
__________________

__________________
Terry and Janet
2008 3001W Windjammer
2007 Ford F150
caper is offline   Reply With Quote
Old 04-05-2015, 07:08 PM   #3
Junior Member
 
Join Date: Apr 2015
Posts: 11
I had the stove running today. Tried a few time with the furnace. Is there a shut off valve for the gas? I found the on off switch on furnace but I don't even smell gas coming through furnace. I can here it trying to click on though. How would I purge the line?
__________________
Sac3100 is offline   Reply With Quote
Old 04-05-2015, 07:12 PM   #4
Mod free 5er
 
Join Date: Mar 2008
Location: Concord, NC
Posts: 24,215
Quote:
Originally Posted by Sac3100 View Post
I had the stove running today. Tried a few time with the furnace. Is there a shut off valve for the gas? I found the on off switch on furnace but I don't even smell gas coming through furnace. I can here it trying to click on though. How would I purge the line?
It will take a few attempts before the air is purged. IF you can get to the gas connection at the furnace, you can loosen it slightly to see if you have gas even flowing. MAKE SURE THE FURNACE IS TURNED OFF AND ALL FLAMES ARE EXTINGUISHED BEFORE DOING THIS! I would even disconnect from shore power also before loosening the line.
__________________
OldCoot is offline   Reply With Quote
Old 04-05-2015, 07:17 PM   #5
Senior Member
 
Jerry01's Avatar
 
Join Date: Oct 2013
Location: Valencia, Ca
Posts: 199
Are your batteries charged? Our heater didn't kick on one time when our batteries were very low. It just blew out cold air. Jerry


Sent from my iPhone using Forest River Forums
__________________
2005 GMC Sierra 2500HD, Duramax 2WD CC/SB
2013 Cardinal 3030RS full body paint
B&W Companion slider, air bags, EFI Live Custom tuning by So Cal Diesel
Jerry01 is offline   Reply With Quote
Old 04-06-2015, 07:07 PM   #6
Member
 
North49's Avatar
 
Join Date: Jan 2015
Location: Canada
Posts: 38
Last weekend I expierenced similar problems, spoke with a dealer and they told me that just because the stove lights it does not mean there is enough to fire the furnace. I also checked the fuse panel and found a blowen fuse for the furnace. Replaced that and the heat came on.
__________________
Brent/Barb -Zoe/Whizabeth wonder dogs
Palimino Columbus 320RS
2014 Dodge Ram 2500 6.7 Diesel
Calgary, Alberta The Stampede City
"The only things in life worth keeping are the things you give away"
North49 is offline   Reply With Quote
Old 04-08-2015, 06:35 AM   #7
Junior Member
 
Join Date: Apr 2015
Posts: 11
Thanks everyone for the help. Talked to the dealer and they think there is somthing wrong with the valve. Still under warranty so bringing it back.
__________________
Sac3100 is offline   Reply With Quote
Old 04-08-2015, 07:35 AM   #8
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Quote:
Originally Posted by Sac3100 View Post
Thanks everyone for the help. Talked to the dealer and they think there is somthing wrong with the valve. Still under warranty so bringing it back.
Please report back so we can learn of the problem!
It may be something we've not seen or overlooked.

TURBS
08 duramax tuned n modded, 32bhok Sabre
2015 camping "2 nights"
__________________
TURBS is offline   Reply With Quote
Old 04-09-2015, 05:28 PM   #9
Junior Member
 
Join Date: Apr 2015
Posts: 11
Ok. I'm bringing it in Monday so will know what's wrong. Let u guys know then.
__________________
Sac3100 is offline   Reply With Quote
Old 04-25-2015, 12:59 AM   #10
Member
 
Join Date: Aug 2014
Posts: 33
So what fixed the heater?


Sent from my iPhone using Forest River Forums
__________________

__________________
Turco14 is offline   Reply With Quote
Reply

Tags
furnace

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:55 PM.