Reply
 
Thread Tools Display Modes
Old 04-06-2012, 11:57 AM   #1
Junior Member
 
Join Date: Aug 2011
Posts: 2
Furnace problem

I have a 2012 Puma fifth wheel and am experiencing problems with the furnace. When first turned on, the unit starts and heats as it should. It may even cycle 2 or 3 times properly but then starts to short cycle and /or blow cold air. Before the 2 or 3rd cycle starts the electonic board in the air conditioner clicks off and on several times. The most annoying part of the furnace cycle is when the flame is extinguished there is a small explosion, sometimes strong enough to rattle the door. I had it looked at by a tech this winter and he suggested the propane regulator was faulty as the propane heater and stove all "popped" when being turned off. I replaced the regulator but the problem has not been cured.

Scorp.
__________________

__________________
scorpion6 is offline   Reply With Quote
Old 04-06-2012, 12:03 PM   #2
CLASS "A" Senior Member
 
cfsoistman's Avatar
 
Join Date: Nov 2008
Location: Upperco, Maryland
Posts: 3,135

Name:   LP Pressure Gauge.jpg
Views: 95
Size:  38.4 KB


Did the tech actually test the regulator? Even if a new regulator is installed you'll still need to check the pressure. It should be set at 11" Water Column by using a U-Tube Manometer or a Gas Pressure Gauge.
__________________

__________________

2007 Georgetown 370TS
aka - RAYNMKR

Driver: Charlie
Navigator: Sheri
cfsoistman is online now   Reply With Quote
Old 04-06-2012, 12:30 PM   #3
Member
 
dezeldad's Avatar
 
Join Date: Jan 2012
Location: West Chester, Ohio
Posts: 74
Sounds very much like an issue I had with my previous trailer. Had the regulator replaced at the dealer under warranty. Problem immediately resurfaced. Did some research and decided to buy a different brand of regulator online and installed it myself ... never had the problem again (kept the trailer another 5 years).

Joe
__________________
dezeldad is offline   Reply With Quote
Old 04-06-2012, 03:55 PM   #4
Junior Member
 
Join Date: Aug 2011
Posts: 2
Yes the regulator was checked with a pressure tester and so was the new one, it was not the same brand as the factory installed one.

Scorp.
__________________
scorpion6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:32 PM.