Thread Tools Display Modes
Old 09-02-2013, 04:23 PM   #11
Senior Member
Brother Les's Avatar
Join Date: Jul 2013
Location: BoCoMo
Posts: 1,586
Originally Posted by ORMelen View Post
We're on our first outing with our brand new 2013 Work and Play 25ULA. Weird thing... The furnace will only kick on if the generator is running. Once it starts up we can shut the generator off and the furnace will continue to run just fine. What's the deal? Is it a setting on the thermostat?

Get your battery load tested.

Brother Les

2013 Forest River Salem Hemisphere SBT312QBUD

2001 CrewCab F-250 7.3 PowerStroke Diesel
SuperChip, BTS transmission, 6.0 Trans Cooler
Brother Les is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 01:15 PM.