Reply
 
Thread Tools Display Modes
Old 04-28-2012, 02:00 PM   #1
Member
 
Join Date: Apr 2010
Posts: 32
furnace wont work

Hello fellow campers, right now as I type i'm camping.However, my furnace is not working!. Here's what it is doing.....it cycles for 30 seconds and shuts off!....there is no "electronic ignition sound"... no smell of the burner lighting..(the gas is on ) it is a "Surburban" furnace hard to see the model the furnace is installed with no labels showing anyone had this issue? haow hard is it to replace an ignitor?
__________________

__________________
cthelite is offline   Reply With Quote
Old 04-28-2012, 02:02 PM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
shut gas back off and wait for a second or two then turn gas valve back on very slowly.
__________________

__________________
TURBS is offline   Reply With Quote
Old 04-28-2012, 02:03 PM   #3
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Also if this is the first use of the season the air may need to be purged .
by lighting surface units on stove .
__________________
TURBS is offline   Reply With Quote
Old 04-28-2012, 04:13 PM   #4
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Turbo's advice for slowly opening the reg and bleeding is spot on. I have to bleed the lines after a few weeks of inactivity.

This manual might help you.

Edit: oops, wrong suburban manual let me see what I can find.
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 04-28-2012, 04:23 PM   #5
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Darn iPad

Here you go...
Attached Files
File Type: pdf Suburban_Tech.pdf (807.3 KB, 67 views)
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 04-28-2012, 04:55 PM   #6
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,165
Can I get a clarification on "cycles"?

So when the unit calls for heat; the blower comes on and runs for 30 seconds; then shuts down?
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is online now   Reply With Quote
Old 04-28-2012, 05:01 PM   #7
Senior Member
 
Malco's Avatar
 
Join Date: Apr 2011
Location: Central Nova Scotia
Posts: 519
Our old Mallard furnace used to do that if we didn't use it for a period of time.I had to do what Turbo said about lighting the stove to get the gas back to the furnace as they were very close to each other.Hope it works for you.
__________________
2011 Salem 30kqbss
2013 Ram 2500
2005 Ram 2500
1968 Pontiac Le Mans
Malco is offline   Reply With Quote
Old 04-28-2012, 08:22 PM   #8
Member
 
Join Date: Apr 2010
Posts: 32
Thanks, but.... my stove is working beautifully so is my water heater. I wanna believe that there is an air pocket preventing gas recpetion.
__________________
cthelite is offline   Reply With Quote
Old 04-28-2012, 08:27 PM   #9
Senior Member
 
Malco's Avatar
 
Join Date: Apr 2011
Location: Central Nova Scotia
Posts: 519
Cthelite when the blower runs can you here the ignition clicking?On ours a few seconds after the blower would start you could here the clicking until the unit would shut down after failing to light.
__________________
2011 Salem 30kqbss
2013 Ram 2500
2005 Ram 2500
1968 Pontiac Le Mans
Malco is offline   Reply With Quote
Old 04-28-2012, 08:40 PM   #10
Member
 
Join Date: Apr 2010
Posts: 32
No..There is no clicking just air blowing for about 30 seconds and it cuts off
__________________

__________________
cthelite is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:06 PM.