Reply
 
Thread Tools Display Modes
Old 11-03-2011, 10:54 AM   #1
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Genesis 2 (ZX85) - B and C speaker problem

Hi Bob and all those who are radio/electronic savvy.

I have a Genesis GT-2.0 (ZX85) in my Flagstaff Shamrock 233S. The radio had been replaced under warranty this summer (wouldn't turn on) but I seem to have a new and different problem that I am at a loss to solve (and so is my dealer).

With the new radio installed, it worked just fine until I turn off the power button. Then, the B and C speakers do not work; only the A speaker. B and C will either hum or click.

The original wiring harness had been used by my dealer when they installed the replacement radio so I thought that the harness could be the problem. I swapped out the old harness with the one that came with the replacement but am experiencing the same problem.

I can "reset" the radio by disconnecting and reconnecting the harness connector from the back of the radio and all speakers start to work. If I turn off the radio and back on after a few seconds, the B and C speakers will hum only.

(By the way, while replacing the harness, I found that FR incorrectly connected the B speaker wires (blue and blue/black). They had wired the blue to the blue/black and the blue/black to the blue. I have corrected that.)

Any thoughts?
__________________

__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 11-03-2011, 11:31 AM   #2
Member
 
tmilicia's Avatar
 
Join Date: Aug 2011
Posts: 68
Yes, take it out and have the dealer replace it again.
I had my 2 week old ZX75 replaced due to poor sound quality from the A & C speaker outputs. I took it out and sent it directly to Forest River and they sent me a new ZX85 (GT2.0) as replacement. After enlarging the mounting hole for the new system and getting it plugged back it sounded much better. However, during a camping trip the following weekend I discovered that this unit wouldn't read any discs that I put in it. So, out came the new ZX85 and back to Forest River it went. I had a new ZX85 replacement the same week and I'm happy to report that this is a good unit (so far). There seems to be quite a few defective concertone's out there, so don't fight with it, just get it replaced. Now that I have a working unit, I'm happy with it.. It has some nice features over the previous model, I just wish there was a better video output option than the "yellow cable", (a RBG component or hdmi would be nice).
__________________

__________________
tmilicia is offline   Reply With Quote
Old 11-03-2011, 01:00 PM   #3
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Quote:
Originally Posted by tmilicia View Post
so don't fight with it, just get it replaced.
Yep - that would be my next step if I can't get anything going with the current unit.
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 11-03-2011, 01:56 PM   #4
Member
 
ddemme's Avatar
 
Join Date: Aug 2011
Location: South Flori-duh!
Posts: 96
Quote:
Originally Posted by tmilicia View Post
Yes, take it out and have the dealer replace it again.
I had my 2 week old ZX75 replaced due to poor sound quality from the A & C speaker outputs. I took it out and sent it directly to Forest River and they sent me a new ZX85 (GT2.0) as replacement. After enlarging the mounting hole for the new system and getting it plugged back it sounded much better. However, during a camping trip the following weekend I discovered that this unit wouldn't read any discs that I put in it. So, out came the new ZX85 and back to Forest River it went. I had a new ZX85 replacement the same week and I'm happy to report that this is a good unit (so far). There seems to be quite a few defective concertone's out there, so don't fight with it, just get it replaced. Now that I have a working unit, I'm happy with it.. It has some nice features over the previous model, I just wish there was a better video output option than the "yellow cable", (a RBG component or hdmi would be nice).
I had my ZX85 off of the wall the other day and it does have RGB output, you just have to get a different wall plate and hook it up.
__________________
Drew & Kendra
Lucky & Bentley the camping dogs
2011 Ford F-150 SuperCrew EcoBoost w/tow pkg.
2012 Rockwood Roo 23SS
ddemme is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:48 AM.