Reply
 
Thread Tools Display Modes
Old 07-03-2012, 06:20 PM   #1
Junior Member
 
thefeniuks's Avatar
 
Join Date: Jul 2011
Location: Canada
Posts: 12
genesis 3.0 DVD surround sound issues

We have an 8312ss and for some reason only certain DVD will play voice over all the speakers. Some we have to turn up load and they only play on the bedroom and right front speaker. Other DVD work fine. Help
__________________

__________________
thefeniuks is offline   Reply With Quote
Old 08-08-2012, 06:06 PM   #2
Senior Member
 
Rockinwood's Avatar
 
Join Date: Oct 2007
Location: Central California
Posts: 277
Quote:
Originally Posted by thefeniuks View Post
We have an 8312ss and for some reason only certain DVD will play voice over all the speakers. Some we have to turn up load and they only play on the bedroom and right front speaker. Other DVD work fine. Help
Looks like no one posted back to you, I just saw this myself, depends what the dvd output is, some, most new ones Either get a 5.1 recording (most of the movie DVD's feature this), or some will only usually older, will be only 2 channel.
__________________

__________________
2007 Rockwood 8317ss Reese Dual cam sway, 2002 Ford Excursion XLT V10,Prodigy Brake controller
Married DW 03/15/97 3 kids
Rockinwood is offline   Reply With Quote
Old 08-08-2012, 07:02 PM   #3
Fulltime family RVer
 
ependydad's Avatar
 
Join Date: Nov 2011
Posts: 14,712
I wish anyone had more information on this. I couldn't get the first two Chronicles of Narnia to play over our DVD player w/ the surround sound. The DVDs say that they're Dolby 5.1, but I could only get the voices to work if I switched the DVD player to have 2 channel output - even then, the sound levels were off.

I even (GASP!) opened the manual - it was worthless with just screen captures of each menu page w/ no descriptions, suggestions or ANYTHING.
__________________
2012 Ram 3500 DRW/crew cab/long bed/4x4/4.10 gears pulling an early 2013 Sabre 36QBOK
Checkout my site for RVing tips, tricks, and info | My family and I have fulltimed since June 2015
ependydad is offline   Reply With Quote
Old 08-14-2012, 01:33 PM   #4
Owner - RVtronics
 
Bob Fields's Avatar
 
Join Date: Jul 2010
Location: Massachusetts
Posts: 649
Send a message via AIM to Bob Fields Send a message via Skype™ to Bob Fields
Try resetting the units to factory defaults by pressing and holding the MODE button (with the power on) until the units shut off. Then try again.

No one should ever really need to touch any of the setup functions and factory default will pay surround sound.
__________________
Bob Fields
bob@rvtronics.com
www.rvtronics.com
(781) 281-9440
Bob Fields is offline   Reply With Quote
Old 10-16-2012, 07:37 PM   #5
Fulltime family RVer
 
ependydad's Avatar
 
Join Date: Nov 2011
Posts: 14,712
Well, 2 months later- I finally got a friend to help me look at this. I have to say that I'm disappointed with my Genesis - it didn't magically send any output to my center channel speaker. After pulling the head unit out, the cable was clearly laying next to all of the others! (Sarcasm.)

Hooked that up and all is well.
__________________
2012 Ram 3500 DRW/crew cab/long bed/4x4/4.10 gears pulling an early 2013 Sabre 36QBOK
Checkout my site for RVing tips, tricks, and info | My family and I have fulltimed since June 2015
ependydad is offline   Reply With Quote
Old 10-16-2012, 08:32 PM   #6
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,336
Quote:
Originally Posted by ependydad
Well, 2 months later- I finally got a friend to help me look at this. I have to say that I'm disappointed with my Genesis - it didn't magically send any output to my center channel speaker. After pulling the head unit out, the cable was clearly laying next to all of the others! (Sarcasm.)

Hooked that up and all is well.
Glad you found it!
__________________

__________________
TURBS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:10 PM.