Reply
 
Thread Tools Display Modes
Old 05-12-2012, 10:49 AM   #1
Senior Member
 
annamarie's Avatar
 
Join Date: Aug 2010
Location: The Heart of the Fingerlakes
Posts: 277
Genesis 3.0 problem solved

I have sent Bob Fields an email, but I was wondering if anyone can help us in the meantime. We had our ZX700 replaced with the Genesis 3.0. The ZX wouldn't let us play Cd's or Dvd's. The surround sound was great though, for all devices. We get it out of storage and had the Sirius and Directv reinstated. The radio and Sirius work great on surround sound but no TV surround sound at all. Also the sub woofer worked great before also, but now can't really hear sound from it and it crackles bad. Thanks for any help with this, as it will be greatly appreciated.
__________________

__________________
David & Annamarie(Fatty & Harley)
2011 Rockwood windjammer(3065)
annamarie is offline   Reply With Quote
Old 05-12-2012, 12:50 PM   #2
Senior Member
 
annamarie's Avatar
 
Join Date: Aug 2010
Location: The Heart of the Fingerlakes
Posts: 277
Problem solved!

I found out the problem with the surround sound, the RCA cable was disconnected somehow at the factory. Connected them back and Great Surround sound now, from the TV.
__________________
David & Annamarie(Fatty & Harley)
2011 Rockwood windjammer(3065)
annamarie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:33 AM.