Reply
 
Thread Tools Display Modes
Old 05-20-2012, 09:22 AM   #1
Senior Member
 
Join Date: Mar 2012
Location: Rutland, VT
Posts: 334
Genesis GT2.0 speaker static

This is a new TT with the Genesis GT2.0 sound system. I have noticed that on speakers B&C there is static no matter which mode it is in (FM, AU1 AV1 etc). On speaker A there is no static whatsoever. Kinda makes me think there may be an internal issue. Thoughts?
__________________

__________________
2016 Chevy Silverado 2500HD Duramax LTZ Z71 Extended Cab, Long bed
2012 Dodge Ram 1500 5.7L Hemi
(with K&N Air Intake) (traded)
2012 Rockwood 2109S (Sold)
2014 Cougar X-Lite 21RBS

wbdvt is offline   Reply With Quote
Old 05-20-2012, 09:33 AM   #2
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
Is there any sound on B and C or just static?
__________________

__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 05-20-2012, 09:36 AM   #3
Senior Member
 
Join Date: Mar 2012
Location: Rutland, VT
Posts: 334
I get sound, it is just that there static in the background on speakers B & C but no static at all on A, just clear sound
__________________
2016 Chevy Silverado 2500HD Duramax LTZ Z71 Extended Cab, Long bed
2012 Dodge Ram 1500 5.7L Hemi
(with K&N Air Intake) (traded)
2012 Rockwood 2109S (Sold)
2014 Cougar X-Lite 21RBS

wbdvt is offline   Reply With Quote
Old 05-20-2012, 10:23 AM   #4
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
If you don't want to do this yourself, just take it in for warranty work. I'm on my third Genesis 2.0 and hopefully my last. My first was replaced because it wouldn't turn on or off consistently and the second was replaced because the B& C speakers wouldn't play anything except snap, crackle and pop

You could check yourself if this is the radio, the wiring, or the B&C speakers by taking out the radio, locating the speaker connections (there's a wiring diagram on the back of the radio) and switch the speaker wires; swapping out the A speaker for the B or C.

Also, check that the B&C connections are tight.

Hope this helps.
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 05-20-2012, 10:53 AM   #5
Senior Member
 
Join Date: Mar 2012
Location: Rutland, VT
Posts: 334
Hi,
I did take it out from the panel and checked all the connections, all tight. They are a crimped connection so it is somewhat of a pain to cut, strip and reconnect to check the individual speakers. I emailed dealer, so I am awaiting their response.
Should I go direct to FR?
__________________
2016 Chevy Silverado 2500HD Duramax LTZ Z71 Extended Cab, Long bed
2012 Dodge Ram 1500 5.7L Hemi
(with K&N Air Intake) (traded)
2012 Rockwood 2109S (Sold)
2014 Cougar X-Lite 21RBS

wbdvt is offline   Reply With Quote
Old 05-20-2012, 11:18 AM   #6
Moderator Emeritus
 
Triguy's Avatar
 
Join Date: Aug 2010
Location: Southeast Wisconsin
Posts: 6,950
I may be the wrong one to ask because I like to DIY but I failed miserably with this radio.

I did everything I knew of - tried two harnesses, swapped speaker A for B, took apart a harness and retightened everything, etc. I got no love from that radio so I finally went back to the dealer.

If that's inconvenient, they can send you a new radio and you install, but I would go through your dealer for that.
__________________
Scott
DW, 3 Kids and our Goldens

2012 Shamrock 233S
2008 Toyota Sequoia 5.7L 4WD
Triguy is offline   Reply With Quote
Old 09-07-2013, 10:06 AM   #7
Junior Member
 
Join Date: Aug 2013
Posts: 1
I'm having the same problem in my 2014. Did to end up getting it fixed and if so what was the problem? Thanks for the help.
__________________
Benike84 is offline   Reply With Quote
Old 09-07-2013, 10:09 AM   #8
Senior Member
 
Join Date: Mar 2012
Location: Rutland, VT
Posts: 334
I got a replacement unit under warranty from the dealer. I brought the original in, exchanged it, installed it and problem solved. I have no static.
__________________

__________________
2016 Chevy Silverado 2500HD Duramax LTZ Z71 Extended Cab, Long bed
2012 Dodge Ram 1500 5.7L Hemi
(with K&N Air Intake) (traded)
2012 Rockwood 2109S (Sold)
2014 Cougar X-Lite 21RBS

wbdvt is offline   Reply With Quote
Reply

Tags
genesis, static

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 06:23 PM.