Reply
 
Thread Tools Display Modes
Old 06-24-2014, 01:20 PM   #11
Site Team
 
Kaadk's Avatar
 
Join Date: Apr 2013
Posts: 3,469
Quote:
Originally Posted by camaraderie View Post
Kaadk...yep...but even more frustratingly...the USB on the 3.0 IS also a charger...you just better have an 8gb player or less! Makes ya wonder where version 3.1 is after 3 years!!
Ah, well, my GT-2.0's USB is not. I had assumed the same of the 3.0. That would be more frustrating.

Quote:
Originally Posted by DaveSchwartz View Post
yaaa.... a bit dumbfounded why no Blu-ray capability in a system in a 2015 5er when the TV is hi-def.
To be fair, the head unit market in general hasn't really caught up to Blu-Ray. The only one I've found is this one from AudioVox: AVDBR1

And it's not even a full head unit, just an add on player with HDMI out.

Most of the market now has recognized that discs are on their way out and are instead jumping right into being able to accept digital inputs.

For instance, looking at Pioneer's NEX line, 3 out of 4 of their models take HDMI inputs.
__________________

__________________
There's no use crying over spilt milk, unless it's on your keyboard.
Kaadk is offline   Reply With Quote
Old 07-27-2014, 03:48 PM   #12
Junior Member
 
Join Date: Jul 2014
Posts: 2
I have a Sabre 2013 34TBOK-6 trailer. We cannot seem to get sound when playing a DVD in the living room (Speaker A). The music plays well but the sound is terrible. Can barely hear the characters and the sub woofer does not seem to be working. Speakers B&C work really well.. Anybody have a solution to this problem. Please and thank you. I do believe our warranty is now expired.
__________________

__________________
slbevans is offline   Reply With Quote
Old 07-27-2014, 06:43 PM   #13
Senior Member
 
camaraderie's Avatar
 
Join Date: Feb 2014
Posts: 1,721
slbevans... if you haven't done so already...try using the AUDIO button on the remote control to set up your DVD sound options BEFORE you insert a disk. That may provide an easy solution. If that doesn't work...
The next step is going into the setup menu to set up both AUDIO and Speakers. The setup button is also on your remote control on the lower left side. There are about 5 sections which you use the direction keys on the remote to navigate to...the 3rd top choice looks like 2 musical notes and sets up your audio choices by navigating to it and then scrolling down. The 5th top choice gives you your speaker choices including subwoofer on and off. See pages 27 and 29 of your manual for the menu choices.
If you don't have the manual...send me a PM with your email and I'll send a pdf of it to you.
Good luck!
Hopefull
__________________
camaraderie is offline   Reply With Quote
Old 07-27-2014, 09:33 PM   #14
Junior Member
 
Join Date: Jul 2014
Posts: 2
Thanks for your suggestions. We have tried everything. We think there is something wrong with the unit. We have spent hours and hours going over it and there is just something wrong.
__________________
slbevans is offline   Reply With Quote
Old 07-27-2014, 10:52 PM   #15
Senior Member
 
camaraderie's Avatar
 
Join Date: Feb 2014
Posts: 1,721
OK...there have been numerous reports of mis-wiring also...so it may be something relatively simple to correct rather than a defect.
Short of taking the unit out for service...you might want to just check the back of the radio wiring for disconnected or shaky connections. Since 2 of the 3 rooms sound OK...a temporary fix might simply be to swap the A wiring with the B or C wiring and see if that give you better sound. If the problem sound also moves to the speakers NOW in the A position...then you know you have a radio problem to be fixed rather than a speaker or wiring problem. While you're doing that...note that positions 1through4 in the C section of your speaker connections are SUPPOSED to be for the subwoofer. If there is nothing there...that is your sub problem! If something is there...and removal of the wire turns a set of regular speakers off...that is also your sub problem!
Good luck!
__________________
camaraderie is offline   Reply With Quote
Old 08-16-2014, 08:36 PM   #16
Junior Member
 
Join Date: Sep 2013
Posts: 10
I have a problem with my Gen-3, where it comes on, at different times, when we're not in the camper. One time it was on when we were loading up to go camping. I turned off and when we stopped on our way to add stuff to the refer, it was on again. Turned it off and when we got to the camp ground, it was on again. It doesn't happen all the time and has never come on while we are in the camper. We try to remember to turn the volume down when we park it at home. My neighbor has come over to tell that the radio is on.
__________________
edwrench is offline   Reply With Quote
Old 08-17-2014, 12:21 AM   #17
Senior Member
 
camaraderie's Avatar
 
Join Date: Feb 2014
Posts: 1,721
You might wanna take the power lead on that and mount it to a toggle switch to insure that it can't turn itself on when you're not there or when you don't want it on.
__________________
________
Cam
2015 Georgetown 280DS
2014 Vespa LX150 2014 StellaAuto 125
camaraderie is offline   Reply With Quote
Old 08-17-2014, 01:45 AM   #18
Senior Member
 
GreenImp's Avatar
 
Join Date: Jul 2013
Location: Oregon
Posts: 620
Send a message via MSN to GreenImp
Quote:
Originally Posted by edwrench View Post
I have a problem with my Gen-3, where it comes on, at different times, when we're not in the camper. One time it was on when we were loading up to go camping. I turned off and when we stopped on our way to add stuff to the refer, it was on again. Turned it off and when we got to the camp ground, it was on again. It doesn't happen all the time and has never come on while we are in the camper. We try to remember to turn the volume down when we park it at home. My neighbor has come over to tell that the radio is on.
Try checking the power button for debris/food/sticky stuff etc....you may get lucky. Check the remote control buttons also...just to be sure. Otherwise, any local electronics shop should be able to fix your problem if you're out of warranty. Personally however, I would dump the Genessis/Concertone in favor of ANYTHING else...even nothing.

I apologize if I sound harsh, but I feel pretty strongly about these brands being garbage. I have been repairing electronics for over 3 decades, and they are one of the most problematic brands I can recall.
__________________
'04 GMC Sierra 2500HD, CCSB, D/A, MaxBrake, B&W Companion, Retrax Pro, AR Power Steps
2013 Rockwood 8289WS w/Diamond pkg
1969 Camaro RS/SS Convertible
Dad's old 1968 Empi Imp (recently recovered from under 21 years worth of boxes/dust)
GreenImp is offline   Reply With Quote
Old 08-17-2014, 08:15 AM   #19
Junior Member
 
Join Date: Sep 2013
Posts: 10
Thank you for the reply. It seems like there is some other electronic signal turning it on, but it never turns off. I have to go in the camper to do that. I guess the most positive way to keep it off, would be with a separate switch.


Sent from my iPad using Forest River Forums
__________________
edwrench is offline   Reply With Quote
Old 08-17-2014, 08:41 AM   #20
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Make sure you turn OFF the "alarm" function.
The "wake with radio" is most likely turning your system on.

Manual attached -
Attached Files
File Type: pdf GT-3.0-5-4.pdf (1.89 MB, 73 views)
__________________

__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:55 AM.