Reply
 
Thread Tools Display Modes
Old 07-26-2013, 12:38 AM   #1
ngg
Junior Member
 
Join Date: Jul 2013
Location: Ontario
Posts: 3
Question GT3 no disc

On my 1st trip with new flagstaff 5th wheel. Playing DVD's has been fine. All of a sudden today after inserting a dvd it briefly loads then displays "no disc" . The book says to clean the disc. Thing is it does it with all including brand new ones. Its raining and grandkids aren't happy.
__________________

__________________
ngg is offline   Reply With Quote
Old 07-26-2013, 09:44 AM   #2
Fulltime family RVer
 
ependydad's Avatar
 
Join Date: Nov 2011
Posts: 14,711
Try "rebooting" the GT3. Cut all power to it for 2 minutes (breaker is likely the easiest) and then turn it back on.
__________________
2012 Ram 3500 DRW/crew cab/long bed/4x4/4.10 gears pulling an early 2013 Sabre 36QBOK
Checkout my site for RVing tips, tricks, and info | My family and I have fulltimed since June 2015
ependydad is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:18 PM.