Reply
 
Thread Tools Display Modes
Old 12-20-2015, 07:31 PM   #1
Member
 
Aca651's Avatar
 
Join Date: Oct 2013
Posts: 79
Heat problem!!!

Using our 2014 flagstaff 8528 BHWS to hide kids presents in. Went today to start wrapping was really looking forward to hanging out in the camper getting Christmas taken care of. Turn the heat on and turns me comes on starts blowing but won't ignite. Got plenty of propane. Turned the burners on the stove and they lit!! Though I did think they were not as large of a flame that I remember. One of my tanks is empty the other one was full. Any thoughts?????
__________________

__________________
Aca651 is offline   Reply With Quote
Old 12-20-2015, 07:45 PM   #2
Senior Member
 
Todouble's Avatar
 
Join Date: Nov 2013
Posts: 849
Regulator may not be giving full pressure out if your stove flame looks wimpy. There notorious for failing. Try cycling the furnace power a few times and see if it will light off.
__________________

__________________
Todouble is offline   Reply With Quote
Old 12-20-2015, 07:51 PM   #3
Left Coast
 
Join Date: Dec 2014
Location: vancouver,washington
Posts: 15,649
Send a message via Yahoo to bob caldwell
If you replace regulator, replace the tank pigtails also
__________________
bob caldwell is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:33 AM.