Thread Tools Display Modes
Old 10-10-2011, 10:28 PM   #1
Junior Member
Join Date: Jul 2011
Posts: 1
Help! 2002 Windsong 326DS, messed up antenna and other accessoies

I have a 2002 Windsong 326DS, we were having trouble with the video selector box and attempted to change it. When I was changing the box I tried to fabricate a power source for our new video selector switch. I used to 12 volt power supply mounted with my Winegard antenna adapter in my entertainment center. Basically to make a long story short I accidentally hooked the wires up backwards and plugged it in. The map lights were on as well as quite a bit of other stuff and got really bright surged and then the light went dead on the Winegard Antenna booster.

So... now my dash cluster (Driving Lights) (Radio) switches dont have power unless the key is in the on positions. they used to have constant power.

My overhead installed concertone radio doesnt sound as crisp (it was not on at the time) and you can hear popping in it when you turn the battery selector switch from use to store located in the stairwell

the light in the switch located in stairwell that operates the stairs is no longer lit.
The GFI in the bathroom just started to give us trouble, not sure if unrelated but the outlet near the range hood seems to be daisy chained from it, as it is sketchy now too.

I removed and replaced the antenna booster, using the factory wires it still didnt have 12 volt at the receptacle. Removed the antenna head and tried it on another camper and it had good reception. reinstalled it in ours and nothing... I ran a new 12 volt power source to the rear of of the receptacle. the light operates and we can receive one channel in our local viewing area, which we used to be able to get many.

I checked all of the fuses in the invertors, the chassis fuses, under the hood and onboard, and in the stairwell. The only place I found any issues was in the stairwell and it was a 5 amp fuse that had been installed in a 7.5 location. I replaced it and still nothing seems to be different.

Is there any suggestions that you may have as to where to begin looking for a short or circuit board that was damaged? I should also mention that the only fuses that I checked were the blade fuses, and the inline that I could locate, (two in stairwell, and one my steering column)

Thank you guys for your help
wannabelowrider is offline   Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:54 AM.