Reply
 
Thread Tools Display Modes
Old 09-30-2014, 01:08 PM   #1
Papi
 
Papicamper's Avatar
 
Join Date: Nov 2011
Location: Dade City, FL (TRR)
Posts: 201
Help! Need quick answer for A/C problem!

The main a/c unit seems to have stopped cooling. I have reset breaker, thermostat system (Dometic) and still no cooling. Unit seems to "go through the motions" of cycling but without any cooling. I have visually inspected roof unit and see no icing or other obvious damage. I was able to touch cond. coil and it wasn't the slightest bit cool. No condensation run off was apparent either.
Question is: Is there another breaker perhaps inside the roof shroud - or some place besides the breaker panel inside? Second unit in bedroom running normally. We're in the middle of a park stay and the chance of having any on-site service here is slim to none.
Any hints appreciated...don't want to tear into it (have ins coverage) but if there's any obvious things I overlooked I sure wouldn't mind looking into them. Thanks!
__________________

__________________
PapiCamper
Cedar Creek 36CKTS
F350 Lariat ("Big Blue")
Papicamper is offline   Reply With Quote
Old 09-30-2014, 01:38 PM   #2
Member
 
kc5mhb's Avatar
 
Join Date: Sep 2014
Posts: 70
I'd contact Dometic with your model number and ask customer support what they think and maybe there are some troubleshooting steps they can recommend that you can do without taking anything apart. Contact - Dometic
__________________

__________________
2015 Cherokee Limited 274DBH
2000 F250 CC SD V10 4X4 8' bed, 4:30 gears, SCT X3
2007 Mustang Convertible V6 - Lots of GT mods
1965 Mustang Coupe I6, 3 spd. manual
1963 Thunderbird Landau 390
kc5mhb is offline   Reply With Quote
Old 09-30-2014, 01:50 PM   #3
Site Team
 
Kaadk's Avatar
 
Join Date: Apr 2013
Posts: 3,469
My brother in law just ran into something similar at the start of the month:

Need emergency help with AC

In his case the control box died and his dealer had to replace it. But there were several suggestions posted in that thread that you might be able to check first.
__________________
There's no use crying over spilt milk, unless it's on your keyboard.
Kaadk is offline   Reply With Quote
Old 10-01-2014, 08:08 AM   #4
Papi
 
Papicamper's Avatar
 
Join Date: Nov 2011
Location: Dade City, FL (TRR)
Posts: 201
Tried both suggestions but...

1. called dometic and they were of no help. Could not offer suggestions beyond obvious (breaker, running fan?, etc).
2. Where's the "control box"? Is it under roof shroud or another box somewhere? I'm reluctant to go much deeper into it as I have the coverage and don't want to invalidate it.
Weather is not stifling...in the low 80s so we'll survive until I can get rig to repair facility I guess but sure would like answer to #2.

Thanks to all!
__________________
PapiCamper
Cedar Creek 36CKTS
F350 Lariat ("Big Blue")
Papicamper is offline   Reply With Quote
Old 10-01-2014, 08:11 AM   #5
Site Team
 
Kaadk's Avatar
 
Join Date: Apr 2013
Posts: 3,469
It's the board inside the unit. Open it up and look for wherever the wires run. As it's a circuit board, there's probably not much you can do in the field if that's what's broken.




Sent from my iPad using Forest River Forums
__________________
There's no use crying over spilt milk, unless it's on your keyboard.
Kaadk is offline   Reply With Quote
Old 10-01-2014, 09:38 AM   #6
Member
 
kc5mhb's Avatar
 
Join Date: Sep 2014
Posts: 70
If you remove the filter, there is a metal box with a bunch of wires going to it. I don't recommend opening it , but there should be a molex type connector on one side that you might check to see if its plugged all the way in. Turn breaker off first though.
__________________

__________________
2015 Cherokee Limited 274DBH
2000 F250 CC SD V10 4X4 8' bed, 4:30 gears, SCT X3
2007 Mustang Convertible V6 - Lots of GT mods
1965 Mustang Coupe I6, 3 spd. manual
1963 Thunderbird Landau 390
kc5mhb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:38 PM.