Reply
 
Thread Tools Display Modes
Old 06-04-2013, 02:24 PM   #1
Junior Member
 
Join Date: Mar 2013
Location: Cypress, Tx
Posts: 10
Hot water issue.

I have a 2012 Sandpiper 365 SAQ and all the sudden my hot water heater quit working on electric. When I switched to gas, it got hot, but doesn't seem to fire backup after using it (shower, dishes, etc) If I turn it off and back on it fires back up. Electric seems intermittent. Going back out this weekend so I'll check again. Still under warranty, but keep it 100 miles from dealer. Never ran with no water, so electric element should be fine.
__________________

__________________
2011 2500 HD Duramax
2012 Sandpiper 365 SAQ
RandyLindsey is offline   Reply With Quote
Old 08-30-2013, 11:58 AM   #2
Junior Member
 
Join Date: Apr 2012
Posts: 3
I have a 2010 Sandpiper and had to replace the elec heating element already - my guess is that's most likely the problem. Not sure why it doesn't cycle properly when on propane.
__________________
johnb658 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:04 PM.