Thread Tools Display Modes
Old 10-22-2012, 12:17 PM   #11
Junior Member
Join Date: Oct 2012
Posts: 8
Our GT-3.0 has had "issues" since we purchased or 2012 windjammer. First no DVD ( dealer hadn't hooked it up). We have camped at 3 different sites since September and None have clear cable ( whole band out of step?). Now the radio, tv speakers, nothing comes on at all! Has the red power button lite up but can get Nothing to work. . We have 3 more days in this beautiful man setting would live to b able to fix this while we r here! HELP!

blessed girlie is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 05:53 AM.