Reply
 
Thread Tools Display Modes
Old 07-14-2013, 11:53 AM   #1
Junior Member
 
Join Date: Oct 2010
Posts: 12
Ignitor Button on Suburban Range

Hi ,
We recently purchased a 2013 Wildwood & the range has(or I should say "had" ) an electronic ignitor button which we found to be great . We had company last weekend & one of the vistors broke the button off .We think that instead of pushing in & turning she pulled it out .Anyway we bought a new button at an RV store but it will not fit on .It is for the correct model because we had the book with us for the model number . Does anyone know anything about this ? Do we need to replace the entire system & just not the button .
Thanks
__________________

__________________
missy9249 is offline   Reply With Quote
Old 07-14-2013, 12:19 PM   #2
Moderator Emeritus
 
Dave_Monica's Avatar
 
Join Date: Sep 2007
Location: Ontario, Canada
Posts: 4,329
I'm assuming that there's still a spindle that the knob pushes onto. Try turning that with pliers and if it still clicks, the piezo assembly should be ok, otherwise you'll need to replace the piezo assembly too.

Dave
__________________


Nights camped in 2013 - 55, 2014 - 105, 2015 - 63
Dave_Monica is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 12:33 PM.