Reply
 
Thread Tools Display Modes
Old 01-14-2016, 08:02 PM   #1
Senior Member
 
Join Date: Apr 2015
Location: Texas
Posts: 306
IRV66 problem

On my 2014 TT I have IRV66 FM/AM/CD/DVD unit. No sound on AM/FM.
When I try to play CD, very little sound, can barely hear it. I have tried the mute button and speaker buttons to no avail. The CD player shows a picture of CD spinning and the different tracks. The FM/AM shows the different stations. Display seems to show everything working, just no sound. I tried holding power button to reset to factory. It was working good at one time. My TT is in storage next to my house. I went out today try out the TT systems. Everything worked except the IRV66 Radio. Any ideas?
__________________

__________________
2015 Flagstaff 26VFKS
TV - 2014 F150 Crew Cab 5.0L
WDH - 1,200 Equalizer
txredfish is offline   Reply With Quote
Old 01-14-2016, 08:19 PM   #2
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 6,477
Try pulling the fuse from the panel and let it set for about a minute or so, then re-install and see if that helps. Sometimes doing a hard reset may fix it.
__________________

__________________
2016 Georgetown 364TS
Nights Camped 2017 - 49
AquaMan is offline   Reply With Quote
Old 01-15-2016, 11:12 PM   #3
Senior Member
 
Join Date: Apr 2015
Location: Texas
Posts: 306
I tried pulling the fuse, putting back in and the IRV66 sound was working. I turned the power off and then back on and no sound. I pulled fuse again and put back in and sound OK. Then turned off power and back on - no sound. I called IRV66 company and they are sending me a new unit. So we will see how that works.
__________________
2015 Flagstaff 26VFKS
TV - 2014 F150 Crew Cab 5.0L
WDH - 1,200 Equalizer
txredfish is offline   Reply With Quote
Old 01-16-2016, 02:10 AM   #4
Member
 
DNBINFV's Avatar
 
Join Date: Aug 2013
Location: Southern Calif
Posts: 99
Many of us have had the same problems, the manufacturer was very easy to deal with. For examples of all the issues people have had with the IRV66 look at the "I RV radio" forum.
__________________
Donna and Bob (retired USAF),
fur babies Casey (mix), Lucy and Loki (standard poodles)

had a 2015 Rockwood 8281 WS - traded for another brand.
2016 RAM 3500
DNBINFV is offline   Reply With Quote
Old 01-31-2016, 03:43 PM   #5
Senior Member
 
Join Date: Apr 2015
Location: Texas
Posts: 306
I called the manufacturer. They sent me a new IRV66 unit. The CD did not work properly and would not eject the CD. I managed to get the CD out by using a post card and pushing the eject button. I called the manufacturer back and they sent me a new one. Everything for now works great. Great people to work with. If anyone has a problem with their IRV unit call Todd Eash at Patrick Industries 574-970-8287.
Just give him the model and date of purchase. You don't need to work through the dealer. Very easy to replace - 4 screws and 4 plugs. They will send you a prepaid shipping label to ship back the old one.
__________________
2015 Flagstaff 26VFKS
TV - 2014 F150 Crew Cab 5.0L
WDH - 1,200 Equalizer
txredfish is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:53 PM.