Reply
 
Thread Tools Display Modes
Old 02-09-2015, 12:31 PM   #1
Senior Member
 
Join Date: Aug 2011
Location: Albany, GA.
Posts: 799
New Dometic t'stat problem

We bought a new unit, Cherokee Freedom Express, three (3) weeks ago then went camping the day after arriving home with it. The temps did a dive at the campground so I wanted to check out the new furnace. When I set the t'stat for the furnace to come on the A/C came on also. Lowering the set point to shut the furnace off also shut off the A/C. I tried the A/C setting and the furnace did not come on with the A/C unit. I would up turning off the A/C breaker to use the furnace. There is also a "FAN" setting so you can turn the A/C fan only on a "LOW" speed and a "HIGH" speed. This is a Dometic t'stat which has on the left hand side from the top down: "FAN", "COOL", and "FURNACE". On the right hand side there are two buttons for "+" and "-" to set the desired temp. I went to a car show/swap meet this past weekend (four days) with some old coot friends and the furnace did the same thing. Again I shut off the A/C breaker to use the furnace. I sent the dealers service department a note after that first weekend and they replied that they had no idea of what this could be nor were they familiar with this particular Dometic t'stat. They want me to bring the unit to them so they can look into this but it's ninety (90) miles away for me. Hoping that someone here can help with this before I have to lug it up to the dealer. Thanks
__________________

__________________
Thurman is offline   Reply With Quote
Old 02-09-2015, 12:38 PM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
You need to put your thermostat on "auto" and then it will all work properly...here is instruction manual....page 9
Attached Files
File Type: pdf Dometic Thermostat- Single Zone Digital.pdf (1.40 MB, 152 views)
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is online now   Reply With Quote
Old 02-09-2015, 12:59 PM   #3
Senior Member
 
Join Date: Aug 2014
Location: West Jordan, UT
Posts: 827
Exactly as fonzie stated. My dealer specifically walked me through this saying it was a common question/concern. He said that power runs to the AC first for circulation and as long as the fan is set in the auto position it will function normally (as you would expect it to). I read the above instructions on page 9 and it is just how my dealer explained it.
__________________
2018 XLR Nitro 36T15
2015 GMC 3500 6.6/Allison

Nights Camped (2017- 16) (2016-13) (2015-13)
SuicideSaints is offline   Reply With Quote
Old 02-09-2015, 01:11 PM   #4
Senior Member
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 9,505
X3 on fonzies' post. Your AC didn't run, just the fan. It happens to alot of people.
__________________
Wiscampsin is offline   Reply With Quote
Old 02-09-2015, 06:43 PM   #5
Senior Member
 
Join Date: Aug 2011
Location: Albany, GA.
Posts: 799
"fonzie": Thanks so much. Ironically I got a phone call from the dealer today telling me the same thing. I keep my TT hooked up in the back yard so I asked the techy to bear with me as I hot-footed it out to the TT. I ran through his instructions as he held on and as "fonzie" described the fan setting was the problem. For What It's Worth "fonzie": The manual you shared the link to is not the manual I have in the TT from the dealer. My little manual (literally 5" x 5") is only four (4) pages. I'm downloading your link so I can print this out and put it in the notebook in the TT. Again--THANKS
__________________
Thurman is offline   Reply With Quote
Reply

Tags
dometic

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:43 AM.