Reply
 
Thread Tools Display Modes
Old 05-08-2016, 10:11 PM   #1
Senior Member
 
m2kamp's Avatar
 
Join Date: Feb 2016
Location: Conroe, TX
Posts: 298
Newbie A/C Help Please -Dometic Brisk II 15k

Having a problem with our Dometic A/C.

It seems to be blowing only cool air now, not ice cold like it was our last trip out.

Now, the temps in Texas have warmed up and humidity is up as well. We got to the campsite around noon and the inside of the trailer was hot (around 90). So we set the A/C to 72, fan on auto and opened the quick cool dump vent then went to the store for supplies. When we got back, the inside of the trailer was still hot and the ac unit was running fan on high but not blowing cold. Occasionally little ice chunks would spit from the return side.

So I opened up the filter intake and looked up and touched the evaporator coil it was also not cold. I could see condensation dripping from the roof gutter outside like normal operation.

Jumped on the forum and searched.

-I reset circuit breakers, ran on fan only hi setting, then switched back to cool, same results - no cold air.

-I taped up the gaps in the divider with A/c foil tape, thinking that the cold air was leaking to the uptake - no improvement.

So next morning, temps fell to upper 60's outside and the ac unit seemed to finally catch up. I used my digital thermometer that has inside temp and a remote temp sensor for outside. I hung the outside temp sensor from the nearest duct register:

At duct - 68 degrees

In RV - 72 degrees

This next day was overcast and only got to about 80 but the temps in the RV steadily increased by the time we left:

At duct - 73 degrees

In RV - 79 degrees

Thermostat setting - 72

Is this normal?

Is there anything I'm missing or should I schedule a dealer visit?

Help
__________________

__________________
2015 Wildwood 26TBSS GVWR 7815lbs/Fastway e2 10k
2016 Ram 2500 CC Tradesman 6.4L 4x4 3.73 GVWR 10000lbs, 3176lb Payload, 12630lb Tow, Max Tongue 1800, GCWR 19800
2017 Ram 1500 CC Lone Star 3.6L 4x2 3.55 GVWR 6800lbs, 1673lb Payload, 7510lb Tow, Max Tongue 1100, GCWR 12900
m2kamp is online now   Reply With Quote
Old 05-08-2016, 10:15 PM   #2
Junior Member
 
Join Date: Feb 2016
Posts: 13
To me it sounds like the unit is low of freon.
__________________

__________________
RBinAlabama is offline   Reply With Quote
Old 05-08-2016, 10:18 PM   #3
Junior Member
 
Join Date: Apr 2016
Posts: 4
+1 on low Freon.
__________________
Wvtroutman is offline   Reply With Quote
Old 05-08-2016, 10:25 PM   #4
Senior Member
 
m2kamp's Avatar
 
Join Date: Feb 2016
Location: Conroe, TX
Posts: 298
Quote:
Originally Posted by RBinAlabama View Post
To me it sounds like the unit is low of freon.
I've learned that these rooftop a/c are sealed (no fill ports), so this means my a/c needs replacement?

Anyone have a similar problem? Hoping I don't have to take it to the dealer...
__________________
2015 Wildwood 26TBSS GVWR 7815lbs/Fastway e2 10k
2016 Ram 2500 CC Tradesman 6.4L 4x4 3.73 GVWR 10000lbs, 3176lb Payload, 12630lb Tow, Max Tongue 1800, GCWR 19800
2017 Ram 1500 CC Lone Star 3.6L 4x2 3.55 GVWR 6800lbs, 1673lb Payload, 7510lb Tow, Max Tongue 1100, GCWR 12900
m2kamp is online now   Reply With Quote
Old 05-08-2016, 10:51 PM   #5
Site Team
 
Flybob's Avatar
 
Join Date: Oct 2014
Posts: 5,555
Dometic has acknowledged that some of the units they delivered in recent years, can have corrosion which causes a leak. Call the dealer, as they have extended the warranty and replace it.
__________________

2015 Freedom Express 248RBS
TV 2015 Silverado HD2500 Duramax
TST Tire Monitors
Honda 2000I + Companion
2 100W solar panels
Flybob is online now   Reply With Quote
Old 05-08-2016, 10:56 PM   #6
Senior Member
 
HONDAMAN174's Avatar
 
Join Date: Jun 2011
Location: Big brown desert
Posts: 2,318
I would see the dealer. Those ac's have a two year warranty. Ours failed 6 weeks before it expired.


2014 Evo 2850 "Woodstock"
2011 Toyota Tundra "Clifford"
__________________
2014 Stealth Evo 2850- "Woodstock"
2011 Toyota Tundra Rock Crawler TRD 5.7- "Clifford"
2013 Honda Accord Coupe V6 w/Track Pack- "Julia"

Just glad to get away
HONDAMAN174 is offline   Reply With Quote
Old 05-08-2016, 11:51 PM   #7
Senior Member
 
BooBoo23's Avatar
 
Join Date: Apr 2014
Location: West Atlanta Metro
Posts: 1,109
Mine quit cooling within a month of being new. My dealer didn't want me to bring in back until he made sure he had a replacement as he didn't want the trailer left there. He had a replacement in stock and when I took it in to the dealer I was there only 2 hours and then gone again.
__________________
2014 Palomino Puma 25RS
2011 F-150 Super Crew XLT
Days camped in 2014 - 23 Camped 2015-47
Camped 2016-71, 2017-33, 2018-29 booked
BooBoo23 is offline   Reply With Quote
Old 05-09-2016, 08:56 AM   #8
Senior Member
 
m2kamp's Avatar
 
Join Date: Feb 2016
Location: Conroe, TX
Posts: 298
Quote:
Originally Posted by BooBoo23 View Post
Mine quit cooling within a month of being new. My dealer didn't want me to bring in back until he made sure he had a replacement as he didn't want the trailer left there. He had a replacement in stock and when I took it in to the dealer I was there only 2 hours and then gone again.
Thanks for the responses guys. I hope my dealer will be as accommodating. I'd hate to have the RV sit at the dealer for weeks/months - not being used.
__________________
2015 Wildwood 26TBSS GVWR 7815lbs/Fastway e2 10k
2016 Ram 2500 CC Tradesman 6.4L 4x4 3.73 GVWR 10000lbs, 3176lb Payload, 12630lb Tow, Max Tongue 1800, GCWR 19800
2017 Ram 1500 CC Lone Star 3.6L 4x2 3.55 GVWR 6800lbs, 1673lb Payload, 7510lb Tow, Max Tongue 1100, GCWR 12900
m2kamp is online now   Reply With Quote
Old 05-09-2016, 09:12 AM   #9
Phat Phrog Stunt Team
 
AquaMan's Avatar
 
Join Date: Apr 2012
Location: Tipp City, OH
Posts: 6,477
The fact that you say that little "ice chunks" were spitting out, almost makes me think that the coil was froze up. If you're making ice, it's getting cold. Could still be the refrigerant.
__________________
2016 Georgetown 364TS
Nights Camped 2017 - 49
AquaMan is offline   Reply With Quote
Old 05-09-2016, 10:55 AM   #10
Senior Member
 
m2kamp's Avatar
 
Join Date: Feb 2016
Location: Conroe, TX
Posts: 298
Quote:
Originally Posted by AquaMan View Post
The fact that you say that little "ice chunks" were spitting out, almost makes me think that the coil was froze up. If you're making ice, it's getting cold. Could still be the refrigerant.
I thought the same. But even during ice chunks the evaporator was not cold to the touch and the freeze sensor was in the correct place on the fins??

I started the a/c the next morning in storage and same result, only cool air.

My 2015 RV was built 6/2014 and I took new delivery on 2/2016.
__________________

__________________
2015 Wildwood 26TBSS GVWR 7815lbs/Fastway e2 10k
2016 Ram 2500 CC Tradesman 6.4L 4x4 3.73 GVWR 10000lbs, 3176lb Payload, 12630lb Tow, Max Tongue 1800, GCWR 19800
2017 Ram 1500 CC Lone Star 3.6L 4x2 3.55 GVWR 6800lbs, 1673lb Payload, 7510lb Tow, Max Tongue 1100, GCWR 12900
m2kamp is online now   Reply With Quote
Reply

Tags
dometic, newbie

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:18 PM.