Reply
 
Thread Tools Display Modes
Old 05-24-2015, 11:06 PM   #1
Junior Member
 
Join Date: May 2015
Posts: 1
No picture from DVD

In my RV I have a Linear Series RV4500 (Magnadyne) system. The first time we went camping we watched DVDs without any problem. Now we get sound but no video. Bought new wires and got the same result. TV is definitely on the right input because if I turn off the A and B speakers on the system the sound comes through the television, just no picture.
Any thoughts? The owners manual for the stereo/multi-media receiver does not have troubleshooting section.
Thus far no overly impressed with my choice of campers. Entirely too many "under warranty" repairs, and it seems every time we use it something else isn't working.
__________________

__________________
artyler is offline   Reply With Quote
Old 05-26-2015, 08:33 PM   #2
Junior Member
 
Join Date: May 2015
Posts: 4
I had the same problem and discovered a disconnected video wire connection between the DVD system and the tv.
__________________
equinox is offline   Reply With Quote
Reply

Tags
dvd

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:23 PM.