Reply
 
Thread Tools Display Modes
Old 04-26-2016, 01:11 PM   #11
Junior Member
 
Join Date: Apr 2016
Posts: 8
That's kinda what I was thinking.
__________________

__________________
mhc02 is offline   Reply With Quote
Old 04-26-2016, 01:12 PM   #12
Senior Member
 
raspivey's Avatar
 
Join Date: Jun 2013
Location: Brazoria County, Texas
Posts: 1,360
A thought just occurred to me...what DVD system do you have? On my Genesis, I seem to recall having problems like that until I realized that I had it on AU1 instead of AV1. I might be mistaken on that though, as I think it's supposed to automatically switch when a DVD is inserted.
__________________

__________________
2015 Chevy Silverado LTZ - HD tow package
2017 Rockwood 2703WS Emerald Edition
raspivey is offline   Reply With Quote
Old 04-26-2016, 01:15 PM   #13
Junior Member
 
Join Date: Nov 2015
Posts: 2
take your radio out of the cabinet and check where they are plugged into the back of the radio i found mine was plugged into the wrong plugs on the radio they are color coded
__________________
Barry and Glenda Byers is offline   Reply With Quote
Old 04-26-2016, 01:31 PM   #14
Junior Member
 
Join Date: Apr 2016
Posts: 8
I also talked with my dealer. He also recommended taking unit out. He said they have had issues with them being installed/hooked-up incorrectly.
__________________
mhc02 is offline   Reply With Quote
Old 04-26-2016, 01:43 PM   #15
Senior Member
 
camaraderie's Avatar
 
Join Date: Feb 2014
Posts: 1,721
The yellow wire contains all the video. Make sure that is plugged into a Video OUT jack on the DVD player and to a yellow video IN jack on the back of the TV. Generally this will be labled as AV1 or AV2 with complementary red & white (right & Left) audio jacks as well. Going into the TV input menu and selecting either AV1 or AV2 should be all you need to do. If that doesn't work...try a new yellow cable to eliminate that as an issue.
If that doesn't work then it is likely the player at issue since the TV works on its' other inputs. Good luck!
__________________
________
Cam
2015 Georgetown 280DS
2014 Vespa LX150 2014 StellaAuto 125
camaraderie is offline   Reply With Quote
Old 04-26-2016, 03:33 PM   #16
Senior Member
 
rmac04401's Avatar
 
Join Date: Sep 2015
Location: Adams County, PA
Posts: 1,989
They had the wires messed up in the pack of my DVD/radio unit. They had yellow video cord hooked up wrong. If you have a fusion the face plate pulls off the an there are screws holding it in. You will want to check the back of the unit and your video cable. Your audio is hooked up right but your video isn't. There is a post on here some where where it gives you the hook up depending on if you want to hear through speakers or just TV.
__________________
2016 Grey Wolf 26rr
2005 Honda VTX 1300
2012 Ram 2500 Crew cab 6.5 bed
5.7L Hemi, 3:73 Rear
Ron & Shirley (Empty Nesters)
rmac04401 is offline   Reply With Quote
Old 04-26-2016, 04:13 PM   #17
2003 Georgetown 325
 
Join Date: Jan 2014
Location: Ocala, FL
Posts: 94
On my flat screen tv I have to back out of the channels until I get "line out" or "line in"....not sure the message. The tv will then show the movie.
__________________
reddiver is offline   Reply With Quote
Old 04-26-2016, 04:18 PM   #18
Senior Member
 
Iwannacamp's Avatar
 
Join Date: Aug 2013
Posts: 4,358
No Video thru TV while playing DVD

I am old...I had issues too. The player and the tv had to change both to play DVD's. I just kept pushing buttons till it worked.

At the time it didn't make sense when it worked, but I just went with it


Sent from my iPhone using Forest River Forums
__________________
2017 Puma 297RLSS
2005 Ram 2500 4X4 diesel
Our new 5er 10-26-16
Iwannacamp is online now   Reply With Quote
Old 04-26-2016, 04:35 PM   #19
Member
 
Join Date: Jan 2016
Location: Colorado
Posts: 87
I was playing around with ours just yesterday to be sure I knew how it operated. I had heard about the issues of wiring being either incorrectly hooked up or not hooked up at all. At first I thought I had the same issue - video was a tv show but the DVDs sound was playing through the speakers. I finally found just I needed to change the source using the tv remote from tv to HDMI. Problem solved.
__________________
2016 Rockwood 2504S
Doxies in the Rockies is offline   Reply With Quote
Old 04-27-2016, 08:31 AM   #20
Junior Member
 
Join Date: Apr 2016
Posts: 8
Got it figured out and working. CAbles were hooked up all wrong on back of DVD player.
__________________

__________________
mhc02 is offline   Reply With Quote
Reply

Tags
dvd

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:16 PM.