Thread Tools Display Modes
Old 01-03-2012, 04:38 PM   #1
Join Date: Mar 2008
Location: Newport, TN
Posts: 81
Only 3 of 5 Interior Speakers Work - set by Slideout are NFG

We bought a like new 2005 Wildwood 37BHSS in early 2008. The prior owners had only used it a handful of times and we have babied it ourselves, so it's in great shape. In fact, we really like our TT!

It comes with a Concertone (not sure which model) that has CD, cassette, AM/FM and Aux inputs. A separate TV/DVD is connected to the AUX and that all works fine, HOWEVER...

...there is a pair of interior speakers located on either side of the slideout that DO NOT WORK and HAVE NEVER WORKED. Doesn't matter which switch position - no sound comes out. I removed one of them and it is wired up like it should be. Also, I doublechecked the wiring harness and it is all completely terminated, as it should be... so I am not sure why there is no sound, but find it hard to believe that BOTH speakers would be bad.

There is also a 3 pos. rotary switch that has a preprinted wording - something like Interior Speakers/Exterior Speakers/Both, or something and there is a speaker selector switch below the cassette deck itself, if my memory serves me. In any case, I tried all the switch position combinations to no avail, on more than one occasion.

Being an engineer myself, my best guess is that it's another "Bad Day at the F.R. factory problem" and that somewhere in that speaker wire run to the slideout speakers there is a connector that was never hooked up and this was not detected during the QC check. This would match up with the other QC problems we have found, such as the poor quality plumbing under the shower stall and the skylight that a 3rd grader could have done a better job installing, because it was never installed flush and later cracked and leaked and had to be replaced(see other postings).

Of course there are other possibilities, such as 2 bad speakers, or damaged wiring somehow, but again, it had this problem from the beginning. As a final footnote, the outside speaker works just fine, as do the other interior speakers... but the set of two small surface mount white speakers mounted next to the slideout are DOA/NF.

Is this a factory defect issue? Have others experienced this same issue? Any suggestions on where to look next to try to fix this? (one thing I did not try is switching one of the "NF" speakers for one of the working speakers, which I could do to test them - although it requires me cutting into the wiring and then reattaching it, which I am not prone to want to do). Any comments are welcomed!

walk_the_walk is offline   Reply With Quote
Old 01-03-2012, 05:31 PM   #2
Senior Member
Koodog's Avatar
Join Date: Feb 2010
Location: Colorado
Posts: 181
I'd start by "wringing out" the speaker wiring in the slideout. Use an ohm meter and see if the wires in fact reach the Concertone, or the switch.
Walt-N-Terry Sanford
03 Dodge Ram 2500 Diesel
08 Rockwood 8317
Koodog is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 04:30 AM.