Reply
 
Thread Tools Display Modes
Old 01-06-2015, 12:12 PM   #1
Member
 
castlemusic's Avatar
 
Join Date: Oct 2013
Posts: 49
Optronics RVFL51 repair

So, I have three of these fan light combos, and one by one, the fans died on them. I assumed it was the motors, so I scoured around the net and found exact replacements, and ordered them. Took them apart, soldered in the new motors, expected to be all done, and... same problem. Fan would run for a few seconds, and then die. So, not the motor.

On closer inspection, there is a resistor on both the high speed AND low speed sides of the motor switch. Why, I don't know. I guess both had gone bad. So, I simply removed the resistors and wired the motor straight to the switch, and it works great now. Obviously I've lost the low speed option, but it really wasn't useful for me anyway, as it was super slow and moved hardly any air at that speed.

I just wanted to share my experience, in case anyone else experienced the same problem. The fact that all three died on me leads me to believe that this might be a more widespread issue.

In an unrelated topic, I have three small brand new 12V motors for sale, very cheap...
__________________
The Castles
Brody, Jeanne & 7 great kids!
2011 Shamrock 233S
2014 Chevy Express 3500
castlemusic is offline   Reply With Quote
Reply

Tags
repair

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:29 PM.


×