Reply
 
Thread Tools Display Modes
Old 09-15-2016, 05:10 PM   #1
Junior Member
 
Join Date: Jul 2016
Posts: 4
Passenger map light

Two issues have popped up on our 2014 Forest River Legacy. First the passenger side map light has gone out. I've checked and there is no power coming to the switch. I've checked all the fuses I can find and all are okay so I don't know what happened to the power! Also, the toggle switch on the dash (below the radio) used to turn the radio on when the ignition switch was in the off position. But now it has to be on AND the ignition switch has to be on before the dash radio will work. This one really has us baffled! Any possible way they are connected? I really need to get her map light working!
__________________

__________________
t17wilson is offline   Reply With Quote
Old 12-21-2016, 12:04 AM   #2
Junior Member
 
Join Date: Oct 2016
Posts: 27
Quote:
Originally Posted by t17wilson View Post
Two issues have popped up on our 2014 Forest River Legacy. First the passenger side map light has gone out. I've checked and there is no power coming to the switch. I've checked all the fuses I can find and all are okay so I don't know what happened to the power! Also, the toggle switch on the dash (below the radio) used to turn the radio on when the ignition switch was in the off position. But now it has to be on AND the ignition switch has to be on before the dash radio will work. This one really has us baffled! Any possible way they are connected? I really need to get her map light working!

I have a related problem. My map lights are fine; I have a diagram for the harness that also covers the cab speakers and corner fans. I could get it to you if that will help. In my situation, the radio works with the ignition on and the rocker switch down. It will not work when the rocker switch is up. In this position, the radio should work from the house batteries and inverter. I researched fuses and the likely ones are good. I am at a loss as what to look at next.

We're you able to solve your problem? Do you have anything that might help me?
__________________

__________________
Richard W Eason is offline   Reply With Quote
Old 12-21-2016, 10:40 AM   #3
Senior Member
 
MNtraveler's Avatar
 
Join Date: Oct 2015
Posts: 1,438
I would check the fuse again. Though it may look OK, it may be bad. Try replacing it with a known good fuse to see if it helps. If not, then see if there is power ahead of and past the fuse. You have to find where the power falls off. Look for any loose connections whether screws or solders.


Land of 10,000 Lakes
2016 Forester MBS 2401R
Nights camped 2016: 32; RV to date: 35
__________________
2016 Forester 2401R
MNtraveler is offline   Reply With Quote
Reply

Tags
light

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:32 PM.