Reply
 
Thread Tools Display Modes
Old 05-19-2019, 01:31 PM   #1
Junior Member
 
Join Date: May 2015
Posts: 13
Radio

blew the fuse in our rockwood 2703ws radio. We replaced the fuse that is behind the radio but now have no sound. Turns on no sound.
__________________

Summerfun2015 is offline   Reply With Quote
Old 05-19-2019, 02:36 PM   #2
Just as confused as you
 
Scrapper's Avatar
 
Join Date: Aug 2013
Location: Wilderness CG, WI
Posts: 3,106
Maybe the connections to the speakers came loose when you pulled out the radio to replace the fuse. The workers are paid piecemeal and sometimes when the workers assemble things they don't take the time to properly connect things. Some owners have reported wires and cables falling from connections just traveling down the road.
__________________

__________________
Richard & Jill
2014 Flagstaff 832IKBS Classic Super Lite
2018 Silverado 1500 Crew Cab Z71 4WD All Star Edition
Camping since 1989, seasonal since 2000
Car Shredder Op/Tech, Scrap Metal Recycling - retired
Scrapper is online now   Reply With Quote
Old 05-19-2019, 03:57 PM   #3
Junior Member
 
Join Date: May 2015
Posts: 13
Scrapper Last winter we took off the antenna we have replaced it is there a certain way they go back on?
Summerfun2015 is offline   Reply With Quote
Reply

Tags
radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by


Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.




Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:04 PM.