Thread Tools Display Modes
Old 06-01-2015, 11:21 AM   #1
Junior Member
Longhorn 105's Avatar
Join Date: Feb 2015
Location: Barnesville, GA
Posts: 13
Radio Antenna

I have a Columbus 360RS and found the antenna was not connected to the radio. It would not receive any radio stations. I think I will have to remove the whole antenna because it looks like the cable that is attached to the base of the antenna was not long enough and they attached an extension cable which I think came unplugged in the wall half way to the radio. Has anyone ever have a problem like this or do you know any other way to fix?

Mike & Patty
2014 Ram 3500 Longhorn 6.7L 4x4
2015 Columbus 320RS
Days Glamping 2015 - 13
Longhorn 105 is offline   Reply With Quote

antenna, radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 10:53 PM.