Reply
 
Thread Tools Display Modes
Old 09-08-2016, 05:44 PM   #1
Senior Member
 
blwnsmoke's Avatar
 
Join Date: Aug 2014
Location: NH
Posts: 318
Relay Clicking issue with Dometic AC/Heat

So hear is an issue I'm having since day 1 of owning my camper. The first time we needed to use the heat, I was woken up by this relay clicking in my rooftop AC unit when needing heat. The clicking was lasting for about 30 seconds and then the blower would turn on and then the flame would ignite.

The clicking would then start again about 30 seconds before the heat would shut off. I basically knew because of this clicking when it would turn on and turn off and it would wake us up several times throughout the night.

Here is where it gets more confusing... this would only happen when the camper was maintaining a temperature that I had set. So example, if I had it set at 72*, it would only do this clicking when it would cycle on and off to maintain the 72*.

If I would go to the thermostat and change it to 73*, it would immediately call for heat and not do the clicking.

While the many times being at camping world for all of my punch list issues, the tech (I've known him for years) found a ground lose and thought that maybe the clicking was due to the ground not making contact at all times. However due to knowing me, he had domestic send him a new control board which apparently everything including the relay is on the control board.

We thought everything was fine until I needed to use my heat for the 1st time this year Labor Day weekend. I was again woken up by this in the middle of the morning but couldn't get my phone out in time to record it.

I decided to sit on the couch until it needed to cycle again and got this on video. Although it is 3 minutes long, watch it especially as it gets to over the 1 minute mark. There is no pattern to the clicking but it is very loud and annoying.

I've just emailed Dometic with a link to my video to see what they say. I'm wondering if it is as simple as a faulty thermostat... not sure what else it could be. This is a ducted AC unit (15k).

Ideas??

" type="application/x-shockwave-flash" wmode="transparent" width="425" height="350">
__________________

__________________
2015 F350 6.7 Platinum
2015 Coachmen 360IBL
blwnsmoke is offline   Reply With Quote
Old 09-09-2016, 07:25 PM   #2
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 3,403
So if I understand, you (the tech) changed the control board, but not the thermostat?

If that's the case then I'd suspect the thermostat. However, you should try and reinitialize the thermostat before you replace it.

Do you have the single zone or the dual zone thermostat?
__________________

__________________
Salem 29RKSS Pushing a 2500 Mega-Cab CTD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 09-09-2016, 07:31 PM   #3
Senior Member
 
blwnsmoke's Avatar
 
Join Date: Aug 2014
Location: NH
Posts: 318
The tech at Camping World replaced the control board but did not replace the thermostat. They did troubleshooting with Domestic and this is what their suggestion was.

The thermostat is a single zone unit.
__________________
blwnsmoke is offline   Reply With Quote
Old 09-09-2016, 08:01 PM   #4
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 3,403
Try initializing it and see if that helps. The procedure for doing it is in the installation manual.
__________________
Salem 29RKSS Pushing a 2500 Mega-Cab CTD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Old 09-20-2016, 06:25 PM   #5
Senior Member
 
blwnsmoke's Avatar
 
Join Date: Aug 2014
Location: NH
Posts: 318
So just to update, I ended up replacing the thermostat on my own. Got it for about $30 out of pocket. Domestic responded back that they are unable to watch the video, my guess is a a firewall. They just sent me back to the dealer.

Talked with service manager today who I know and showed him the video.. he has never seen anything like it before. So new control board with relay, new thermostat.. will attempt my camping trip on Columbus Day weekend to see what happens.

Didn't want to drop it off, waste their time with them trying to troubleshoot especially if the problem is resolved. Plus it may stay their for a week or two.. Just not worth the headache over $30 if this solves it. If not, well then we have eliminated the thermostat and we are back to the AC unit.

We shall see in a few weeks.
__________________
2015 F350 6.7 Platinum
2015 Coachmen 360IBL
blwnsmoke is offline   Reply With Quote
Old 09-21-2016, 10:26 AM   #6
Head Rambler
 
Join Date: Mar 2008
Location: Southwest Alabama
Posts: 3,403
Thanks for reporting back. Please keep us informed if that fixed the problem.
__________________

__________________
Salem 29RKSS Pushing a 2500 Mega-Cab CTD!
Gotta go campin!
Bama Rambler is offline   Reply With Quote
Reply

Tags
dometic

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off




» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 07:08 AM.