Thread Tools Display Modes
Old 06-17-2012, 10:04 PM   #1
Junior Member
Join Date: Mar 2011
Posts: 20
Snowy Cable TV

First time using the cable tv system in a 2005 Surveyor. Picture was snowy on the flatscreen TV. Had the camp techy look at the problem. Snow came from the two TV outlets in camper, problem did not go away when the amplifier was turned off or on. Techy then ran a cable from outside directly to my tv thru the doorway, snow went away. Techy said the problem must be in my trailer cable wiring. I then used the antennae to receive tv, and there was no snow.

When I got home I removed the front tv outlet and seen only one cable at that outlet. The rear outlet that also has the amplifier has three cables attached to the backside. Is the snow maybe coming from the cable that feeds from the outside?

98xlt98 is offline   Reply With Quote
Old 06-17-2012, 10:18 PM   #2
one day at a time
Idle_Idylist's Avatar
Join Date: Apr 2011
Posts: 128
Could be a bad fitting or a faulty amp over driving the picture

2012 Ford F250
2016 Salem 27Dbud
Blue Ox BXW1000 WDH
Idle_Idylist is offline   Reply With Quote
Old 06-17-2012, 10:25 PM   #3
Senior Member
Iggy's Avatar
Join Date: Jul 2010
Location: Desert SW - Arizona
Posts: 5,887
Some rigs have 2 hookups on the outside. One for cable and one for Satellite. Are you sure it goes into the correct one?

Maybe the previous owner has it setup for a SAT dish on the outside then into a receiver then into the set.

Either way the present cable from the outside is not reaching the TV sets and the splitter.
2012 Georgetown XL - 378TS 49,000 miles
(2013 - 98 days) (2014 - 117 days) (2015 - 67 days) (2016 - 115 days)
USAF Retired - MSgt

Iggy is offline   Reply With Quote
Old 06-18-2012, 08:55 AM   #4
Junior Member
Join Date: Mar 2011
Posts: 20
When I said snowy, that meant I could see the stations, but most had a snowy appearance. None had a clear looking appearance like it was with the over-the-air channels.

When I told the TV to look for cable channels, it did find about 40 channels. So some part of the exterior cable system did work.

There is only one exterior cable connection on this model 233T.
98xlt98 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Virginia Campgrounds

Reviews provided by is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities

Copyright 2002-2015 Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:09 AM.