Reply
 
Thread Tools Display Modes
Old 06-02-2013, 08:44 PM   #1
Member
 
JackRAbbit's Avatar
 
Join Date: Oct 2012
Posts: 33
Stereo system problems

We went out camping this weekend and experienced two problems.
We have a 2013 Rockwood 8285WS.
The first problem was that the stereo system has stopped working. When I dewinterized it a week ago everything was fine. When we went to use it this weekend, the stereo would not come on and also the XM Radio would register and channels.

I have ruled out a problem originating with the XM Radio because it works in the truck.

I have not done any trouble shooting yet, but I am guessing (hoping) that it is only a problem with a breaker or fuse.

Also I am hoping that the XM radio issue is also related to the stereo issue.

Has anybody had similar issues and am I on the right track.
__________________

__________________
JackRAbbit is offline   Reply With Quote
Old 06-02-2013, 08:59 PM   #2
Senior Member
 
amxpress's Avatar
 
Join Date: Nov 2007
Location: Clayton, NC
Posts: 683
Who made your stereo?
__________________

__________________
2013 Palomino Columbus 320RS
2007 Dodge RAM 2500 6.7 Cummins
Reese 15K manual slider
Prodigy
M.I.L. in Florida for good!!
amxpress is offline   Reply With Quote
Old 06-02-2013, 10:20 PM   #3
Member
 
JackRAbbit's Avatar
 
Join Date: Oct 2012
Posts: 33
The stereo is the Genesis GT3.0 that came as a factory install and the satellite radio is XM and not Surius.
__________________
JackRAbbit is offline   Reply With Quote
Old 06-02-2013, 10:42 PM   #4
Senior Member
 
Join Date: Feb 2012
Location: Wisconsin
Posts: 9,512
IMHO you're on the right track by first checking fuse or breaker.
__________________
Wiscampsin is offline   Reply With Quote
Old 06-03-2013, 10:53 PM   #5
Member
 
JackRAbbit's Avatar
 
Join Date: Oct 2012
Posts: 33
Electronics is weird. I took out the fuse to check it. Everything was fine. I put the fuse back in and low and behold the stereo and XM Radio started to work again.
__________________
JackRAbbit is offline   Reply With Quote
Old 06-04-2013, 08:13 AM   #6
Wanna Be Camper
 
SaskCampers's Avatar
 
Join Date: Mar 2010
Location: Moose Jaw, Saskatchewan
Posts: 2,370
Quote:
Originally Posted by JackRAbbit View Post
Electronics is weird. I took out the fuse to check it. Everything was fine. I put the fuse back in and low and behold the stereo and XM Radio started to work again.
With the Concertone / Genesis that is generally the first thing to do as it reboots the unit as they sometimes have a tendancy to lockup.
__________________

John & Deb
2011 F250 Lariat FX4 Crew Cab 6.2
2011 Flagstaff V-Lite 30WRLS
Days Camped 2016: 3 2017: 0
SaskCampers is offline   Reply With Quote
Old 06-04-2013, 08:34 AM   #7
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,169
Any surround sound radio is more computer than radio these days.

CTRL-ALT-DLT (Power completely off) works 90% of the time.
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 06-04-2013, 08:57 AM   #8
Senior Member
 
rattleNsmoke's Avatar
 
Join Date: Oct 2012
Location: Western Connecticut
Posts: 1,571
The other 10% you just acquired a boat anchor.
__________________

__________________
2010 Cedar Creek 5th Wheel 34SATS "The Beast"
2006 Ford F350 Lariat 6.0L Diesel
2003 Harley Heritage Softail "Hogzilla"
1986 Marriage to "Wifey" (patience of a saint)
rattleNsmoke is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 08:56 PM.