Reply
 
Thread Tools Display Modes
Old 10-15-2011, 08:15 AM   #1
Member
 
hoovercab's Avatar
 
Join Date: May 2011
Location: Northeast corner of CT
Posts: 65
Suburban Oven Issue

We were camping last weekend, We set up and I tried to light the pilot on the oven. I was able to light, but when you turn the knob to light the burnner you get nothing. The pilot light gets really wide but will not light. We thing that it may be the regulator as we smell no gas, and when you try to manual light the burner nothing happens. Any feed back or suggestions? This is the first issue that we have had with it. I have attached 2 photos not sure if they will help, but one is the pilot light and the second is what happens when I try to light the burner.
Thanks
Attached Thumbnails
Click image for larger version

Name:	Pilot light.jpg
Views:	55
Size:	50.3 KB
ID:	8509   Click image for larger version

Name:	Lighting oven.jpg
Views:	79
Size:	47.0 KB
ID:	8510  
__________________

__________________
Sheldon & Kathi Hartwell
Dexter and Ryley our beagles
2003 Forest River Flaggstaff 829 BHSS
2001 Lincoln Navigator All Wheel drive
hoovercab is offline   Reply With Quote
Old 10-15-2011, 08:23 AM   #2
Senior Member
 
Join Date: Sep 2010
Location: Ontario Canada
Posts: 752
You have probably a bad thermocouple and it is preventing to open the way to the gas for the tube. I would try another thermocouple at your place to see if it will work. Since your trailer is a 2003 there is a good chance that it needs replacing for this part. Cost less than 20$
__________________

__________________
capucine is offline   Reply With Quote
Old 10-15-2011, 11:32 AM   #3
Senior Member
 
Boyd's Avatar
 
Join Date: Aug 2010
Location: Iron River, MI
Posts: 372
Quote:
Originally Posted by capucine View Post
You have probably a bad thermocouple and it is preventing to open the way to the gas for the tube. I would try another thermocouple at your place to see if it will work. Since your trailer is a 2003 there is a good chance that it needs replacing for this part. Cost less than 20$
Yep, that would be my guess too.
__________________
"If everything seems to be going well, look around, you've obviously overlooked something."
Boyd is offline   Reply With Quote
Old 10-16-2011, 08:45 AM   #4
Member
 
hoovercab's Avatar
 
Join Date: May 2011
Location: Northeast corner of CT
Posts: 65
Suburban Issue

Thanks for your help, but it looks like we may be replacing the whole unit. I called 3 places and Suburban no longer has that part listed. They have check to see if they change the part number, but no luck. I am waiting to hear from the dealer in our area that is really great at getting parts, but if she has no luck then the unit is going to be replaced. We currently have a Suburban SR3SWWM it is the short oven, suburban part # is 161207 (Thermocouple). If anyone know of a company that may have one I would love the part instead of a new range. Thanks again!!!!!
__________________
Sheldon & Kathi Hartwell
Dexter and Ryley our beagles
2003 Forest River Flaggstaff 829 BHSS
2001 Lincoln Navigator All Wheel drive
hoovercab is offline   Reply With Quote
Old 10-16-2011, 08:55 AM   #5
Senior Member
 
Boyd's Avatar
 
Join Date: Aug 2010
Location: Iron River, MI
Posts: 372
I think you will find your part here:

Rv Thermocouple Manufacturer Part Number 161207 Upc Code 799530703122
__________________
"If everything seems to be going well, look around, you've obviously overlooked something."
Boyd is offline   Reply With Quote
Old 10-16-2011, 04:16 PM   #6
Senior Member
 
Join Date: Sep 2010
Location: Ontario Canada
Posts: 752
I am sure that you can get a universal one for your replacement. On my previous older trailer I was able to get a universal thermocouple for my water heater and it would fit perfect.
__________________
capucine is offline   Reply With Quote
Old 05-25-2012, 09:06 AM   #7
Member
 
hoovercab's Avatar
 
Join Date: May 2011
Location: Northeast corner of CT
Posts: 65
UPDATE;
I have been going at it with Suburban and I had to replace my range(not with a Suburban). Suburban said that my range doesn't have a thermocouple. We had a gas safety valve that was made with mercury and the EPA stopped them for making the ranges this way. They did not do a refit becasue I was told not may of them made, but us poor RV's that do have them are not getting any help from Suburban. My stove was brand new condition!! Boy this just burns my butt!!! I will never buy another Suburban product again, the lack of support and Oh tuff luck from them just burnned our bridge!!!!
__________________
Sheldon & Kathi Hartwell
Dexter and Ryley our beagles
2003 Forest River Flaggstaff 829 BHSS
2001 Lincoln Navigator All Wheel drive
hoovercab is offline   Reply With Quote
Old 05-25-2012, 09:12 AM   #8
Site Team
 
MtnGuy's Avatar
 
Join Date: Sep 2008
Location: Virginia Blue Ridge Foothills
Posts: 7,880
We had a 2003 Trailmanor with a Suburban stove and the same problem....the pilot would light, but the burner would not. A local (non Trailmanor) RV dealer resplaced the safety valve, and all was good after that.

I don't know if my stove had the mercury safety valve or not, but you might want to check around a bit with RV dealers/mechanics to see if there are other solutions.
__________________

Chap , DW Joy, and Fur Baby Sango
2006 Ford F150 Super Cab 4x4
2008 Surveyor 263
MtnGuy is offline   Reply With Quote
Old 05-25-2012, 09:33 AM   #9
Member
 
hoovercab's Avatar
 
Join Date: May 2011
Location: Northeast corner of CT
Posts: 65
Thanks Chap,
We went through 2 different RV dealers that we use. Neither could find the part number and one sent me the scematic and asked me if I could use it to nail down the part. There was no part number for what we needed. The part was shown but, no number. That's when I contacted Suburban for help and got no satifaction. We have purchase a Atwood. I and happy with this stove/oven. We went a bit bigger. We are just really down on Suburban right now.
__________________

__________________
Sheldon & Kathi Hartwell
Dexter and Ryley our beagles
2003 Forest River Flaggstaff 829 BHSS
2001 Lincoln Navigator All Wheel drive
hoovercab is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off






ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


All times are GMT -5. The time now is 03:52 PM.