Reply
 
Thread Tools Display Modes
Old 11-11-2014, 09:15 PM   #1
Junior Member
 
Join Date: Nov 2014
Posts: 13
Took delivery today, and problems when we got home

Well, we picked up our 2015 Salem 32BHDS today. Everything went well during the PDI and pickup. We drove home 90 minutes, and now we have issues. Our unit has the "showstopper" package with power stabilizer jacks and awing, controlled both by manual switches on the unit and the handheld touchscreen remote. The remote no longer controls the stabilizer jacks or awing. The front stabilizer jack and awing still work with the manual switches on the unit. The rear stabilizer is completely dead. The remote still operates the slides and porch light. During the PDI, I did not personally use the remote, but the tech working with us put it through its paces. The remote takes a great deal of pressure to execute commands, and sometimes multiple "key" presses. We have a year warranty, and I am sure that the dealer will take care of the issues, but if this is simple fix I would like to avoid a three hour round trip. Thanks!
__________________

kberlen is offline   Reply With Quote
Old 11-12-2014, 12:37 AM   #2
Senior Member
 
jtstromsburg's Avatar
 
Join Date: Jul 2011
Location: Stromsburg, Nebraska
Posts: 1,679
No real knowledge, but I would try disconnecting all power to camper, 110v & 12v. Maybe that will reset something. The rear stabilizers sound like a fuse maybe?
__________________

__________________
Joel and Teresa
2016 Sabre 34TBOK
2006 GMC 3500 CC LB DRW 4X4
jtstromsburg is offline   Reply With Quote
Old 11-12-2014, 01:09 AM   #3
Senior Member
 
Cypressloser's Avatar
 
Join Date: May 2014
Location: Alberta - East of the Rockies, West of the Rest
Posts: 1,654
Try to locate the control panel control panel for your stabilizers, awnings and everything else controlled by your remote pad. It has it's own separate fuses that can burn out when two functions are accessed simultaneously.

Oh, and congrats to the new trailer
__________________
2018 RAM 5500 Laramie CC
Riverstone Legacy 38RE, 960 Watt Solar, 6x6 Volt AGM Battery Bank, Freedom SW 3012 Inv/Charger
Cypressloser is offline   Reply With Quote
Old 11-13-2014, 12:45 PM   #4
Junior Member
 
Join Date: Nov 2014
Posts: 13
I unplugged the unit and disconnected the battery for about 5 minutes. When I hooked everything back up, the remote would operate the front stabilizer and awning again. The rear stab is still dead. Will check for a blown fuse in the control board for the remote control next. Thanks!
kberlen is offline   Reply With Quote
Old 11-13-2014, 02:31 PM   #5
Senior Member
 
KenHwy61's Avatar
 
Join Date: Jan 2014
Location: Minnesota
Posts: 756
Congratulations on your new trailer! I can relate to some of your issues. My Aviator has some of that kind of remote control gadgetry although not to the point of the awning and jacks. While a cool idea in theory, and maybe others have had better experiences, but for me, the remote control touch screen tablet and keyless entry have shown to be more trouble than they are worth. On the bright side, all the manual pushbuttons have been completely trouble free!
__________________

Seasonally in the Grand Marias, MN campground
On the beautiful shores of Lake Superior

Aviator Wright-Flyer#1908
2012 Ram 2500HD CTD
KenHwy61 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Featured Campgrounds

Reviews provided by

Disclaimer:

This website is not affiliated with or endorsed by Forest River, Inc. or any of its affiliates. This is an independent, unofficial site.



Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:21 PM.


×