Reply
 
Thread Tools Display Modes
Old 05-26-2015, 07:25 AM   #1
Junior Member
 
Join Date: Sep 2014
Posts: 8
Tv and radio problems

New to all this. Need help in figuring out what to do with the antenna on my 2015 salem 26tbud. It doesn't pick up any tv channels. Also it will sometimes work but most other times not work with picking up radio stations. What are your suggestion in taking care of this problem.

thanks in advance.
__________________

__________________
tdccbc is offline   Reply With Quote
Old 05-26-2015, 07:34 AM   #2
Senior Member
 
Stormrider151's Avatar
 
Join Date: Sep 2011
Location: South East
Posts: 915
There is a small button on the wall plate where the coax cable plugs into the trailer. It is for the amplifier. A light will come on when the amp is on. This has to be on for the TV to work.
__________________

__________________
Retired Fire Dept Battalion Chief
2016 Ever-Lite 232RBS
2012 F150 FX4 W/Max tow & Ecoboost

Getting old ain't for wimps!!!
Stormrider151 is offline   Reply With Quote
Old 05-26-2015, 08:01 AM   #3
Junior Member
 
Join Date: Sep 2014
Posts: 8
Yea i have the on. we have never received a signal from the antenna. I have had to try a regular house small antenna and it worked twice but not very well. Went this weekend with no tv and no radio. Is there a way to replace the antenna that comes with it or is that a good antenna?
__________________
tdccbc is offline   Reply With Quote
Old 05-26-2015, 08:09 AM   #4
Senior Member
 
Join Date: Mar 2014
Posts: 1,748
Can you explain what type of equipment you have. That will help in trying to diagnos the issue.
__________________
Still Kickin is offline   Reply With Quote
Old 05-26-2015, 08:13 AM   #5
Junior Member
 
Join Date: Sep 2014
Posts: 8
The antenna is a fixed antenna on the roof. can't rotate it or anything. when i looked at it it had to metal wings on each side and then the basic entertainment center to run dvd,radio,etc. there is the wall plate with the amp on it with the coax to tv from that.
__________________
tdccbc is offline   Reply With Quote
Old 05-26-2015, 08:26 AM   #6
Junior Member
 
Join Date: Sep 2014
Posts: 8


here is what the entertainment looks like
__________________
tdccbc is offline   Reply With Quote
Old 05-26-2015, 02:14 PM   #7
Senior Member
 
Stormrider151's Avatar
 
Join Date: Sep 2011
Location: South East
Posts: 915
Sometimes it's a setting on the TV. I'm guessing you have already tried this but your TV should be set to on air and not cable. A channel search also helps sometimes. Next I would make sure the coax is actually attached. There have been instances where the coax behind the wall plate has not been attached or not attached at the antenna itself. Good luck, I know it's frustrating. I've been there myself.
__________________
Retired Fire Dept Battalion Chief
2016 Ever-Lite 232RBS
2012 F150 FX4 W/Max tow & Ecoboost

Getting old ain't for wimps!!!
Stormrider151 is offline   Reply With Quote
Old 05-26-2015, 03:20 PM   #8
Member
 
Join Date: Oct 2014
Location: West, Texas (the town, not the western part of the state)
Posts: 45
I have a 2014 Salem Lite and we had the same problem the first time out. We just have the wall plate with the Antennae and Cable jacks.

Someone on the forum here had posted that the labels on the face place were wrong and once we attached to the Cable we got a lot of antennae stations. Go figure.
__________________
All who wander are not lost, most times we just forgot the map.
kralspace is offline   Reply With Quote
Old 05-26-2015, 03:52 PM   #9
Senior Member
 
Join Date: Sep 2014
Posts: 129
My Pheonix 33ck has the same problems. I think most of the problems is in the fixed antenna. Never had this problem with old winegard.
__________________
Rick_Geneseo is offline   Reply With Quote
Old 06-02-2015, 06:52 PM   #10
Junior Member
 
Join Date: Sep 2014
Posts: 8
Sorry it took so long. I got on the camper roof and took apart anteena. It had a cable going in where I couldn't try to tighten it. The bottom of the anteena had that it was 3.3 dbs.
__________________

__________________
tdccbc is offline   Reply With Quote
Reply

Tags
radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 02:03 PM.