Reply
 
Thread Tools Display Modes
Old 08-20-2014, 06:11 AM   #1
Member
 
Join Date: Jan 2013
Posts: 44
TV and radio trouble

I looked a little this morning but didn't find anything relating to the same issues I am having with the tv and radio. They may well be connected. I don't know. The tv is like stop action. Works for a short time then the picture freezes for a short time, jumps to catch up and starts and stops over and over again. The radio has a similar problem. Plays for a very short time then static - a lot. very irritating. Trailer is a Work and Play toyhauler (WPT28DB)

thanks
__________________

__________________
scout3351 is offline   Reply With Quote
Old 08-20-2014, 06:18 AM   #2
Senior Member
 
fonzie's Avatar
 
Join Date: Sep 2010
Location: Eastern Ontario
Posts: 3,237
Could it be because of LED lighting if you have in your unit ??

LED Electrical Noise
__________________

__________________
Fonzie
2011 Rockwood 8319SS with ProPride 3P hitch/GoodYear Marathons/TST TPMS 507
2008 F250 Lariat CC SB 6.8L V10 4.10 axle ratio (NITTO TERRA GRAPLER G2 LT275/65R20E)
Yamaha 3000iseb generator:Progressive Ind. EMS-HW30C : Eastern Ontario
Nights Camped: 2011(21) 2012(36) 2013 (17) 2014 (18) 2015 (18) 2016 (36) 2017 (32)
fonzie is offline   Reply With Quote
Old 08-20-2014, 07:27 AM   #3
Senior Member
 
RSchleder's Avatar
 
Join Date: Apr 2014
Location: Iowa
Posts: 1,277
We have full LED trailer and the DVD and TV work perfectly!
__________________
Days camping (2016)----181 days
Days camping (2017) --- 82 days
2016 Wildcat MAXX 28RKX (33' TT), 2007 13' Scamp
2015 Ram Laramie Hemi, w/air suspension
30 years RV'ing
12 different RV's
RSchleder is offline   Reply With Quote
Old 08-21-2014, 12:04 PM   #4
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Quote:
Originally Posted by scout3351 View Post
I looked a little this morning but didn't find anything relating to the same issues I am having with the tv and radio. They may well be connected. I don't know. The tv is like stop action. Works for a short time then the picture freezes for a short time, jumps to catch up and starts and stops over and over again. The radio has a similar problem. Plays for a very short time then static - a lot. very irritating. Trailer is a Work and Play toyhauler (WPT28DB)

thanks
Not much to go on.

How old is the camper?
Did it just start doing this behavior?
Is it only when using "Over The Air" (roof antenna).
What kind of TV?
What kind of radio?
How far to closest TV/Radio tower?

Have you used a tower finding program like www.TVfool.com or www.AntennaWeb.org to find out if you have reliable digital radio/TV reception?
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 08-23-2014, 07:48 AM   #5
Member
 
Join Date: Jan 2013
Posts: 44
Camper is 2008 Work and Play toyhauler and we have had this problem since we bought it from PO. We usually camp out in the sticks or along the river so are not using anything but the roof antenna. The TV is a Polaroid flat screen and the radio is, I think, a Jenson. Whatever Forest River puts in. The trailer is sitting right next to my shop and the radio in the shop plays fine. TV has a good clear picture when it's not screwing up and usually finds 10 - 12 channels when scanning.
__________________
scout3351 is offline   Reply With Quote
Old 08-23-2014, 12:25 PM   #6
Site Team - Lou
 
Herk7769's Avatar
 
Join Date: Oct 2009
Location: South Eastern PA
Posts: 21,168
Do you routinely remove the radio from the camper?

Is there a different antenna for the radio? - could be a broken core wire

Do you turn the TV antenna to point the white box at the TV towers you need to tune on?
__________________

Lou and Laura with Bella - German Short Hair Pointer
2008 GMC Sierra 2500HD Crewcab SB Allison Duramax
2010 Flagstaff 8526RLWS - Superglide 3300
HAM CALLSIGN - KC3FFW
Herk7769 is offline   Reply With Quote
Old 08-23-2014, 04:15 PM   #7
Member
 
Join Date: Jan 2013
Posts: 44
Radio is built in - never leaves camper and has separate antenna. TV antenna is round so it does not get moved. Seems strange to me that both pieces of electronics are having problems.
__________________
scout3351 is offline   Reply With Quote
Old 08-23-2014, 04:21 PM   #8
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,840
Start with the basics, are all of the connectors wired and grounded correctly and tight?

This is from the antenna to the back of the radio and tv.

In a thread which I can not find now someone posted that they found the ground shielding cut off on some connections.
__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Old 08-23-2014, 08:26 PM   #9
Member
 
Join Date: Jan 2013
Posts: 44
I'm going to go through everything tomorrow and hopefully can find something. I was working on relocating my LP tanks tonight and was soaked from the heat and humidity. I was kneeling on the ground and leaning against the tongue and was getting a little tingling where I touched the trailer. Anywhere I touched ground and the trailer I got bit. Could this be part of the problem?
__________________
scout3351 is offline   Reply With Quote
Old 08-23-2014, 08:35 PM   #10
Senior Member
 
Ford Idaho's Avatar
 
Join Date: Sep 2013
Location: Idaho
Posts: 9,840
Quote:
Originally Posted by scout3351 View Post
I'm going to go through everything tomorrow and hopefully can find something. I was working on relocating my LP tanks tonight and was soaked from the heat and humidity. I was kneeling on the ground and leaning against the tongue and was getting a little tingling where I touched the trailer. Anywhere I touched ground and the trailer I got bit. Could this be part of the problem?
If you are sure it was not caused by static then yes it is a real problem.

If you have it plugged in, how, power or extension cord?
__________________

__________________
2016 F350 6.7L LB CC Reese 28K 2014 Chaparral Lite 266sab
"Those who would give up essential Liberty, to purchase a little temporary Safety, deserve neither Liberty nor Safety." 2014 19 days camping 2015 17 days camping201620 days camping
Ford Idaho is offline   Reply With Quote
Reply

Tags
radio

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 11:22 PM.