Reply
 
Thread Tools Display Modes
Old 10-16-2014, 09:04 AM   #1
Junior Member
 
Join Date: Oct 2014
Posts: 4
Unknown Entertainment Brand

I recently purchased a 2010 Flagstaff Super Classic Lite FLT831rlbss. It was a bank repo and had no manuals for installed equipment. I cannot figure out how to operate the stereo system,surrond sound or outside speakers. The factory installed system does not have a name on it so I have no idea on what owners manual to try and download. Anyone out there that can help with this matter? Thanks
__________________

__________________
fisherslanding is offline   Reply With Quote
Old 10-16-2014, 09:10 AM   #2
Phat Phrog Stunt Team
 
TURBS's Avatar
 
Join Date: Aug 2011
Location: Iowa
Posts: 34,337
Most likely a concertone unit.


Turbs
__________________

__________________
TURBS is offline   Reply With Quote
Old 10-16-2014, 11:02 AM   #3
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,050
Quote:
Originally Posted by fisherslanding View Post
I recently purchased a 2010 Flagstaff Super Classic Lite FLT831rlbss. It was a bank repo and had no manuals for installed equipment. I cannot figure out how to operate the stereo system,surrond sound or outside speakers. The factory installed system does not have a name on it so I have no idea on what owners manual to try and download. Anyone out there that can help with this matter? Thanks
I have a 2011 Flagstaff 831 RLBSS and may be able to help if that's the same as yours.

As Turbs stated, it may be a Concertone/Genesis.

Look at the gallery here in this link and see if yours matches up with any pictured. I have the ZX690 in mine.

Concertone® Product Gallery

Once we establish what you have, we'll go from there.

I'm also going to move this thread to the electronics section.
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is offline   Reply With Quote
Old 10-20-2014, 09:44 AM   #4
Junior Member
 
Join Date: Oct 2014
Posts: 4
Thanks for the help. I saw the pic of the radio I have in my camper. It was the ZX690 Concertone. Now I just have to figure out how to operate it. I feel that connections have been removed. I pulled the unit out and it has a lot of wires hooked up behind it. I just have to figure out how to get the surround sound and other speakers to work. I have reset the function button to get it to return to default settings. When I press the power button it comes on briefly and then goes out. it has power but will not stay on. Oh well, i'll figure it out, just have to keep messing with it. Thanks again for the help.
__________________
fisherslanding is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 09:57 AM.