Reply
 
Thread Tools Display Modes
Old 01-18-2015, 01:27 PM   #11
Senior Member
 
Join Date: May 2013
Location: Florida
Posts: 303
Quote:
Originally Posted by wdw0528 View Post
Hello,

This is likely the first of many posts from me as I learn my way around the rig we just bought....a used 2013 Forest River Flagstaff 8528 fifth wheel.
Using a checklist I found here I did a good inspection (I hope).
Everything worked as expected except the water heater....it heated with propane but not with AC power. The previous owner said he "thought" that it was not AC capable but there is a switch behind the outside cover and I turned it to the on position and the gas off but no luck. Any ideas on where to start troubleshooting would be appreciated....or is it possible that it does not have AC option?

Thanks in advance for any input!

wdw0528
We have that same year and model. It DOES have both propane AND electric capability for the water heater. There are two switches, one behind the outside water heater door and it seems you have found that one. The second switch is the 15A circuit breaker in the electrical panel just to the right as you enter the trailer. Reset the breaker by moving the handle OFF, then back ON. If you still aren't heating water on electric, then indeed you may have a damaged electrical element as another poster described. The water heater MUST be filled with water prior to turning on the electrical switches.
__________________

__________________
2013 Flagstaff 8528IKWS, 2006 F-350 6.0L
DickiedooFlagman is offline   Reply With Quote
Old 01-18-2015, 04:07 PM   #12
Member
 
Join Date: Dec 2014
Posts: 70
Problem solved guys.....thanks much for all the input. I checked circuits, made sure of water and tried again and its working nicely. Not sure if I corrected an electrical input problem or if I just hadn't alloed enough time yesterday to get good results.
__________________

__________________
Darrell & Kathy
2013 Flagstaff 8528IKWS 5er
2013 Ford F250 6.7 Diesel
B&W Companion Slider
wdw0528 is offline   Reply With Quote
Old 01-18-2015, 05:46 PM   #13
Member
 
Join Date: May 2014
Location: Ontario, Canada
Posts: 89
Send a message via Skype™ to stillontheroad
Water heater on 110

Based on what you have said, the previous owner probably drained his Hot water tank and left the 110 switch on before he filled it again (winterized). That would burn out the 110 element. Relatiely inexpensive to replace but you may need a special tool to remove the element (unusuall socket size) But that too is available from most RV dealers.
__________________
stillontheroad is offline   Reply With Quote
Old 01-18-2015, 05:57 PM   #14
Site Team
 
Mr. Dan's Avatar
 
Join Date: Mar 2014
Location: Grayson County, Texas
Posts: 6,238
Quote:
Originally Posted by stillontheroad View Post
Based on what you have said, the previous owner probably drained his Hot water tank and left the 110 switch on before he filled it again (winterized). That would burn out the 110 element. Relatiely inexpensive to replace but you may need a special tool to remove the element (unusuall socket size) But that too is available from most RV dealers.
Read post #12 (just above yours)... problem solved.
__________________
SEARCH is your friend!
FR Wildcat 295RSX / GMC Sierra

Nights Camped: '13 = 49 / '14 = 74 / '15 = 74 / '16 = 85 / '17 = 110 / '18 = 0; booked = 28
Mr. Dan is offline   Reply With Quote
Old 01-18-2015, 06:39 PM   #15
Site Team
 
wmtire's Avatar
 
Join Date: Nov 2010
Location: Northeast Louisiana
Posts: 15,021
Quote:
Originally Posted by wdw0528 View Post
Problem solved guys.....thanks much for all the input. I checked circuits, made sure of water and tried again and its working nicely. Not sure if I corrected an electrical input problem or if I just hadn't alloed enough time yesterday to get good results.
Excellent.
__________________
2011 Flagstaff 831 RLBSS

Ducks are just all-terrain chickens
wmtire is online now   Reply With Quote
Old 03-12-2015, 11:55 PM   #16
Member
 
Join Date: Mar 2015
Location: California
Posts: 87
Water Heater won't work on 110

I have a 2011 Wildwood that I bought used. Took it in to Camping World to have a HotRodd installed for electric. Service called me back and told me it only needed the electric run to a dedicated outlet. Factory never finished the installation! They hooked it up at a very nominal cost and I saved a pretty penny. Disappointed though in the manufacturer quality control. By the way, the breaker was in the box and marked.
__________________

__________________
wildwoodtraveler is offline   Reply With Quote
Reply

Tags
heater, water, water heater

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



» Virginia Campgrounds

Reviews provided by




ForestRiverForums.com is not in any way associated with Forest River, Inc. or its associated RV manufacturing divisions.


Copyright 2002- Social Knowledge, LLC All Rights Reserved.

All times are GMT -5. The time now is 03:32 AM.